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1
Welcome to SOLIDWORKS 2025

This chapter includes the following topics:

• Top Enhancements
• Performance
• For More Information

SOLIDWORKS® 2025 contains user-driven enhancements that help streamline and accelerate
your product development processes from concept to manufacturing:

• Accelerate time to market with enhanced collaboration and data management
• Streamline workflows for parts, assemblies, drawings, MBD, electrical and pipe routing,
ECAD-MCAD collaboration, and rendering

• Work faster with import/export, user experience, and performance improvements
• Streamline drafting workflows with accuracy and clarity with DraftSight® updates
• Increase data efficiency with SOLIDWORKS PDM updates
• Ensure performance and accuracy with SOLIDWORKS Simulation updates
• Streamline electrical design with SOLIDWORKS Electric Schematic and Electrical Schematic
Designer updates

• Continue to design anywhere with the latest in browser-based product development on the
3DEXPERIENCE® platform
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This document covers all enhancements that affect how you interact with the 3DEXPERIENCE
platform. This includes both of the platform-connected versions of SOLIDWORKS -
SOLIDWORKS Connected and SOLIDWORKS with the 3DEXPERIENCE (Design with
SOLIDWORKS) add-in. It also includes other apps that can connect to the platform such as
DraftSight.

Top Enhancements
The top enhancements for SOLIDWORKS® 2025 provide improvements to existing products
and innovative new functionality.

Fundamentals • Specifying a Z-Up Template on page 25

Parts and Features • Defeature Silhouette Method for Parts on page 43
• Patterning Reference Geometry on page 44
• Repairing Dangling Relations on page 39

Assemblies • Assembly Visualization on page 65
• SpeedPak Instances on page 69
• Interference Detection in Large Design Review Mode on
page 70

SOLIDWORKS MBD • Creating DimXpert Dimensions from Sketch Dimensions
on page 162

Performance
SOLIDWORKS® 2025 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

Features
The quality and performance of pattern features is improved, especially for editing and
rebuilding. Examples:

• If the seed feature of a pattern is another pattern, the seed feature is not highlighted.
• If the seed feature has more than 100 faces, the seed feature is not highlighted.
• For newly created patterns that use the Instances to Vary option, performance and
accuracy are improved.

• The performance is improved when you edit or click OK to create patterns that have
a large number of instances or faces.

Assemblies
Performance is improved when calculating mass properties for an assembly.
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SOLIDWORKS PDM
SOLIDWORKS PDM performance is improved during the file check in to the SOLIDWORKS
PDM database when the data transfer over the internet is slow. The file check in operation
is two times faster than before.

Sheet Metal
You can experience improved performance while working with multibody parts with a
large number of cosmetic thread features when you enable the Shaded cosmetic threads
option.

For sheet metal parts with multiple cosmetic thread features, performance is improved
for these operations:

• Opening parts
• Creating new features
• Editing features
• Updating and rebuilding parts

Performance is improved while working with drawings that contain drawing views of sheet
metal parts with many holes and forming tools. When working with such drawings, you
can experience improved performance for:

• Opening drawing files
• Making new drawings from the sheet metal part
• Updating drawing views after making edits to the sheet metal part

Sketching
Performance is improved when rendering for smooth zooming, panning, and rotating of
complex sketches.

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML

• > What's New > PDF

• > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Online Help
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Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE® platform (login required).

SOLIDWORKS User
Forum

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices
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2
Using SOLIDWORKS on the 3DEXPERIENCE Platform

This chapter includes the following topics:

• Publishing Cut List Items on the 3DEXPERIENCE Platform (2025 SP1)
• Removal of Option to Generate 3D Format
• Visibility of Quantity Column
• Quick Tours
• Linking Configuration Properties of Representations to Physical Products
• Licensing Support for SOLIDWORKS CAM, SOLIDWORKS Inspection, and

SOLIDWORKS MBD Add-Ins
• Task Pane
• Accepting or Rejecting Parent-Child Relationships in IDX Files(2025 SP1)

This chapter covers all enhancements that affect how you use SOLIDWORKS® with the
3DEXPERIENCE® platform. Unless otherwise noted, the entries in this chapter are available
in both SOLIDWORKS Connected (3DEXPERIENCE SOLIDWORKS roles) and in SOLIDWORKS
with the 3DEXPERIENCE (Design with SOLIDWORKS) add-in (Collaborative Designer for
SOLIDWORKS role).
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Publishing Cut List Items on the 3DEXPERIENCE Platform (2025 SP1)

You can publish cut list items of a weldment part on the 3DEXPERIENCE platform.

To publish the cut list items, save the SOLIDWORKS part as a weldment part to the
3DEXPERIENCE platform. The side panel displays the extension of the weldment part as
SW Weldment Part.

Prerequisites to save the SOLIDWORKS part as a weldment part:

• You must have already saved the part on the 3DEXPERIENCE platform.
• The part must contain a weldment feature.
• The part must be a Single Physical Product.

Prerequisites to publish cut list items on the 3DEXPERIENCE platform:

• The part must be a weldment part.
• The cut list must be up to date.
• The cut list item property must have the CutlistID.

To publish cut list items on the 3DEXPERIENCE platform:

1. With a weldment part open, click Options (Standard toolbar), select the Document
Properties tab, and then select Weldments.

2. In the Document Properties - Weldments dialog box, under Cut list IDs, select
Generate Cut list IDs and click OK.

3. In the 3DEXPERIENCE Task Pane, right-click the part and click Save.
4. In the Save to 3DEXPERIENCE dialog box, select Publish cut-list items and click

Save.

MySession displays cut list items of the weldment part. The side panel displays the
properties of the cut list items.

Administrators can define custom PLM attributes and mapping between CAD items and
PLM items for saving attributes on the 3DEXPERIENCE platform.
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Removal of Option to Generate 3D Format
The Compute 3D format for all configurations option is removed.

Benefits: You can continue working in SOLIDWORKS while the output is getting generated.

The option was added on the Settings Page of Collaborative Spaces Configuration
Center > CAD Collaboration > SOLIDWORKS. The CGRs are now generated using
the Conversion Service for cloud environment and Derived Format Converter for
on-premises environment.

Visibility of Quantity Column

The Quantity column in MySession is visible or hidden based on the tree view option
selected in the Options dialog box.

Benefits: You get the flexibility to show or hide the Quantity column.

The Quantity column displays the number of instances associated with an object. The
values displayed are based on the selected Tree View type in the Options dialog box.
The column is visible when you select Reference View or FeatureManager Tree View
option.
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Quick Tours

3DEXPERIENCE users can follow compact, integrated learning modules called Quick Tours.
Each Quick Tour has a sequence of steps shown as interactive popups that point to
elements in the user interface.

Benefits: You can interactively learn the 3DEXPERIENCE apps to help you quickly
understand basic functionality and concepts. For information on best practices, see
SolidPractices.

To access Quick Tours, in the Welcome dialog box, on the Learn tab, click Quick Tours.

To start a Quick Tour, click a tour, for example User Interface Overview. To progress
through the steps, click Next inside the popup step. The popups include the step numbers
so you can gauge your progress.
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Linking Configuration Properties of Representations to Physical Products

SOLIDWORKS links the configuration properties of representations to their physical
products.

You can overwrite the values of representations that are linked from the physical products.
Show Representations lets you display the representations of physical products in the
left panel.

For linking between physical products and representations of legacy files that are
compatible with the 3DEXPERIENCE platform and saved:

1. In the FeatureManager® design tree, right-click the file.
2. Select Link properties in representations.

Licensing Support for SOLIDWORKS CAM, SOLIDWORKS Inspection, and
SOLIDWORKS MBD Add-Ins

If you own licenses for SOLIDWORKS CAM, SOLIDWORKS Inspection, and SOLIDWORKS
MBD, you can enable them to run in SOLIDWORKS Connected.

Benefits: The add-ins install automatically, making these tools readily available within
SOLIDWORKS Connected.

When installing SOLIDWORKS Connected, optionally select an add-in and enter your serial
number. If you are using a network license, you must specify the address (port@server)
of your SolidNetWork (SNL) License server.

Once you install the add-in:

• You can activate or deactivate stand-alone versions from the Help menu in
SOLIDWORKS Connected.

• SNL versions retrieve a license from the license server when you add them.
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For SOLIDWORKS Inspection specifically, when you install SOLIDWORKS Inspection with
SOLIDWORKS Connected, the add-in and stand-alone app are installed and updated. The
stand-alone app offers the same features as the SOLIDWORKS Installation Manager
version. You can start the stand-alone app from the desktop shortcut or the Windows
Start menu, not from the 3DEXPERIENCE Compass. The stand-alone app also supports
the same activation methods and SolidNetWork (SNL) licensing.

Task Pane

Enhancements to the user interface help improve productivity.

In Design with SOLIDWORKS® and SOLIDWORKS Connected, the Task Pane shows
3DEXPERIENCE Files on this PC as the second tab. When you turn off the 3DEXPERIENCE

tab, 3DEXPERIENCE Files on this PC is the first tab. In earlier releases, 3DEXPERIENCE
Files on this PC was the last tab.
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Accepting or Rejecting Parent-Child Relationships in IDX Files(2025 SP1)

You can manage and accept or reject changes in parent-child associations, whether
updates come from ECAD or MCAD.

CircuitWorks now supports parent-child associations between components and other
board items, such as keep-in, keep-out, plated holes, and non-plated holes, when
interacting with IDX3.0 files. You can accept or reject changes to these items from either
ECAD or MCAD.

Benefits:

• Accept or reject all associated changes in one action, regardless of whether the updates
originate from ECAD or MCAD.

• When modifying parent components in MCAD, all related child items are updated
automatically during the export to CircuitWorks.

To use this feature, do the following:

1. Click Tools > CircuitWorks > CircuitWorks Options
2. Select ProStep EDMD and select Use parent-child association in IDX

communication.
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3
Installation

This chapter includes the following topics:

• Convert SolidNetWork License Server to 64-Bit
• Installing the SOLIDWORKS Manage Web API

Convert SolidNetWork License Server to 64-Bit
The SOLIDWORKS® SolidNetWork License Manager 2025 installs as a 64-bit application.
This change does not affect functionality or user experience.

Installing the SOLIDWORKS Manage Web API
You can install the Manage Web API in the SOLIDWORKS PDM InstallShield Wizard. During
the installation, you can either use the default port or specify another value for the Http
port.

In addition, in the SOLIDWORKS Installation Manager, you can install the Manage Web
API on the SOLIDWORKS Manage Server page and specify the Http port there as well.
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4
Administration

This chapter includes the following topics:

• Inheriting Default File Locations When Upgrading to SOLIDWORKS 2025
• SOLIDWORKS Login Manager

Inheriting Default File Locations When Upgrading to SOLIDWORKS 2025

The logic for inheriting file locations from previous installations has improved. Previously,
you had to modify or reset file locations when upgrading because of default file locations
from earlier installations.

Default file locations now follow this logic:

• If you kept the default file location in an earlier installation, SOLIDWORKS® 2025
creates and uses a new default file location when you first run the software.

• Any new sheet formats and document templates added in the previous default location
are integrated into the 2025 default file locations. The integration includes any new
files referenced in ProgramData\SOLIDWORKS\SOLIDWORKS version.

There is no change if you customized file locations to custom paths. SOLIDWORKS 2025
continues to inherit custom paths from earlier installations. Custom paths exist outside
of ProgramData\SOLIDWORKS or the SOLIDWORKS installation folders.
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The data in the SOLIDWORKS installation directory is updated only if SOLIDWORKS is
installed in the Windows Program Files folder. If SOLIDWORKS is installed outside this
folder, file locations inherit custom paths.

SOLIDWORKS Login Manager
The SOLIDWORKS Login Manager, installed by the SOLIDWORKS Installation Manager,
allows login to the 3DEXPERIENCE Marketplace and 3DEXPERIENCE apps.

When installing an administrative image using the command line or through Microsoft
Active Directory, you must include the SOLIDWORKS Login Manager file in the image.
For example: administrative_image_directory\swloginmgr\SOLIDWORKS Login
Manager.msi.
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5
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Sharing Files on 3DDrive and 3DSwym (2025 SP1)
• Changes to System Options and Document Properties
• Application Programming Interface
• Specifying a Z-Up Template
• Saving SOLIDWORKS Inspection Files Using Bookmarks

Sharing Files on 3DDrive and 3DSwym (2025 SP1)

You can use the Share tool to share SOLIDWORKS files on 3DDrive and 3DSwym without
installing the Design with SOLIDWORKS app.

3DDrive and 3DSwym let you securely share data with your team directly from
SOLIDWORKS.

To share files on 3DDrive and 3DSwym:

1. In a SOLIDWORKS document, click File > Share.
2. Specify the app.

• To share on 3DDrive, select Share File.
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• To share on 3DSwym, select Share in Community.

3. If you did not sign in, click Log In and enter your 3DEXPERIENCE credentials to
access the app.

If you experience issues with accessing 3DSwym or 3DDrive, see Steps to activate
your 3DEXPERIENCE platform.

4. In the app, complete the required fields and click Upload for 3DDrive or Publish for
3DSwym.

Changes to System Options and Document Properties
The following options have been added, changed, or removed in the software.

System Options

AccessDescriptionOption

ColorsSpecifies the colors shown for the mesh
faces when you use the Insert > Mesh
> Segment Imported Mesh Body or
Convert Mesh to Standard tool. See
Colors > Color scheme settings.

Recognized mesh face

Unrecognized mesh face

ExportMaps custom properties to IFC™ property
sets. See Export > File Format: IFC
> Output as.

Use Property Set
mapping file

InstallationThe logic for inheriting file locations from
previous installations has improved. See
Inheriting Default File Locations
When Upgrading to SOLIDWORKS
2025 on page 20

File Locations

DrawingsWhen you open a drawing, you have the
option to have it automatically zoom to
fit your graphics area.

Zoom to fit on open

23

SOLIDWORKS Fundamentals



Document Properties

AccessDescriptionOption

Sheet MetalSOLIDWORKS® automatically adds length
dimensions to all edge flange profiles,
where the sketch dimension (not the
feature dimension) controls the flange
length.

Automatically add Flange
Length dimension to
flange profiles

Surface FinishesSelect a standard:
• 21920-1
• 1302 (1992)
• 1302 (2002)

Surface symbol standard

Chamfer
Dimension
Tolerance

Select a tolerance:
• None
• Bilateral
• Limit
• Symmetric
• MIN
• MAX
• Fit
• Fit with tolerance
• Fit (tolerance only)

Tolerance type

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

• Ability to import annotations into drawings
• Photorealistic rendering with SOLIDWORKS Visualize through the SOLIDWORKS API.
Appearance support for the SOLIDWORKS Visualize API add-in includes:

• Access to new IRenderMaterial properties
• Ability to add or edit floor appearances of model scenes
• Texture mapping of nonlinear surfaces, including surface projections

• Improved performance:

• When reloading a SOLIDWORKS model from disk
• With component objects
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Specifying a Z-Up Template

When you create a part or assembly, you can choose a template for Z-up orientation.

When you create a part, you can choose Y-up or Z-up and build on the template. In earlier
releases, SOLIDWORKS had a default Y-up orientation only.

The Y-up and Z-up orientation settings are available only for the default templates that
SOLIDWORKS creates.

You can specify a SOLIDWORKS default Z-up template when you create a new
SOLIDWORKS document.
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After a new installation, you can specify the default orientation in the Units and Dimension
Standard dialog box.

To specify a Z-up template when you create a new SOLIDWORKS document:

1. Click New (Standard toolbar) or File > New.
2. In the dialog box:

a. Select a type of document, such as part or assembly.
b. Specify an option:

• Y-up. The Y-axis points upward.
• Z-up. The Z-axis points upward.

c. Click OK.

To specify a Z-up template in the Units and Dimension Standard dialog box:

1. Access the Units and Dimension Standard dialog box:

a. In the lower-right corner of the graphics window, in the task bar, click IPS.
b. Specify units:

• MKS (meter, kilogram, second)
• CGS (centimeter, gram, second)
• MMG (millimeter, gram, second)
• IPS (inch, pound, second)

c. Click Edit Documents Units....

2. In the Units and Dimension dialog box, under Orientation, specify an option:

• Y-up. The Y-axis points upward.
• Z-up. The Z-axis points upward.

3. Click OK.
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Saving SOLIDWORKS Inspection Files Using Bookmarks

You can save SOLIDWORKS Inspection files to the 3DEXPERIENCE® platform using
bookmarks.

To save SOLIDWORKS Inspection files using bookmarks:

1. Open a project or create a new project, and from MySession, right-click the file and
click Save.

2. In the Save to 3DEXPERIENCE dialog box, click Add Bookmark.
3. In the Bookmark Editor, right-click Bookmarks and select New Bookmark.
4. In the New Bookmark window, for Title enter a name for the bookmark and click

Create.
5. Select the new bookmark.
6. Specify an option and click Apply.

a. Add Existing. Adds the newly created bookmark to existing bookmarks.
b. Upload file. Uploads an existing file.

7. To save the bookmark to the 3DEXPERIENCE platform, click Save.
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6
User Interface

This chapter includes the following topics:

• Simplified Interface (2025 SP1)
• Command Predictor
• Reorganize Components
• Usability
• Hole Wizard
• Save and Auto Save Progress
• Create Document Group

Simplified Interface (2025 SP1)

Simplified Interface is a workspace that presents the SOLIDWORKS window with an
abridged user interface. The window includes basic user interface elements tailored to
the type of document that you open.

With a document open, click View > Workspace > Simplified Interface.

Without a document open, click View > Simplified Interface.

When selected, the status bar indicates the Simplified Interface workspace.
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If you use the Simplified Interface workspace, customize the interface for your needs,
then turn off Simplified Interface, SOLIDWORKS saves any customizations that you
made if you turn on Simplified Interface again.

Heads-Up View Toolbar
For parts and assemblies, the Heads-up View toolbar contains tools to manipulate views.
It does not include appearances, scenes, or view settings.

Default interfaceSimplified interface

CommandManager
The CommandManager displays one tab per document type. The tabs are Basic Modeling
Tools, Basic Assembly Tools, and Basic Drawing Tools which contain commonly used tools
for those document types.

Default interfaceSimplified interface

Task Pane
The Task Pane contains the following tabs:

• 3DEXPERIENCE

• Design Library

• View Palette

• Appearances, Scenes, and Decals
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Default interfaceSimplified interface

You can specify tabs to include. On a Task Pane tab, right-click and select Customize.

FeatureManager Design Tree
The FeatureManager design tree contains the following items:

• Equations

• Material

• Planes

• Origin

• Sketch

Default interfaceSimplified interface
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You can specify items to include in Tools > Options > System Options >
FeatureManager under Hide/show tree items.

Items in the FeatureManager design tree do not include configuration or display state
names if only one exists. You can turn this option on or off. In the FeatureManager design
tree, right-click a part or assembly name and click Tree Display > Component Name
and Description. In the dialog box, clear Do not show Configuration or Display
State name if only one exists.

PropertyManagers
Several PropertyManagers contain collapsed sections:

Default interfaceSimplified interface

Sketch Mode
For parts, the Simplified Interface opens a new part with an active sketch on the Front
plane.

You can turn this option on or off in Tools > Options > System Options > Sketch and
clear Create sketch on new part.
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MotionManager Tree
The MotionManager tree is hidden.

Command Predictor

The Command Predictor predicts the tools that are most relevant based on the tools you
used in the current SOLIDWORKS session. It reduces the time that you spend searching
for tools that you are likely to use next.

To use the Command Predictor:

1. In a SOLIDWORKS document, click the Command Predictor (beta) tab
(CommandManager).

2. Click a tool on the tab.

The Command Predictor is beta functionality and tool suggestions are based on a
machine learning model.
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Reorganize Components
Enhancements to the user interface help improve productivity.

The Reorganize Components dialog box has moved to a PropertyManager. The dialog box
no longer obscures the graphics area.

Usability
The user interface is enhanced to improve productivity.

Fillet to Chamfer Naming

In the FeatureManager® design tree, when you right-click a fillet and select Convert Fillet
to Chamfer, the FeatureManager design tree changes the fillet name to chamfer. You
can use Convert Chamfer to Fillet as well and the software updates the name
accordingly. In earlier releases, the fillet name remained in the FeatureManager design
tree.
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Unsuppress the Sketch Automatically

In the FeatureManager design tree, you can right-click a suppressed sketch you want to
edit, select Edit Sketch, and the software unsuppresses the sketch automatically. In
earlier releases, you received this notification:

Material Dialog Box - Favorites Tab

In the Material dialog box, after you add a new material to Favorites, you can click Close
or x in the upper-right corner to save the changes and close the dialog box. In earlier
releases, when you clicked x, the software did not save the changes.
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Material Dialog Box - Custom Tab

In the Material dialog box, after you add a new material from Custom Materials to
Custom, and click x, you receive the following notification:

In earlier releases, you only received the notification when you clicked Close.

Flyout Menu in Customize Dialog Box

In the Customize dialog box, the Select tool is available under the flyout toolbars.
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Hole Wizard

Enhancements to the user interface help improve productivity.

When you click Hole Wizard (Features toolbar), the Hole Type icons are clearer to
distinguish.

Save and Auto Save Progress

36

User Interface



Enhancements to the user interface help improve productivity.

When you save files to the 3DEXPERIENCE platform, the software shows messages to
indicate the software is saving your files.

While you save a file on the 3DEXPERIENCE platform, the software shows a progress bar
and displays "Save in progress..." in the status bar.

While a file autosaves on the 3DEXPERIENCE platform, the software shows a progress
bar and displays "Auto Save in progress..." in the status bar.

Create Document Group
You can save all open files in SOLIDWORKS as a single document group. This lets you
open all the files saved in that group at once. In earlier releases, you had to open every
file individually.

Creating Multiple Files as a Document Group

To create a document group:

1. In a SOLIDWORKS document, click Window > Create Document Group.
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The Create Document Group dialog box contains a list of open files in SOLIDWORKS.

2. In the dialog box:

a. Select the required files.
b. Click Create.

The software shows a success notification. A message notifies you that
SOLIDWORKS created Document Group and you can access it from the Recent
tab in the Welcome dialog box.

Updating a Document Group

When you create new parts, you can save the parts as part of a previously created
document group.

To update a document group:

1. Open the parts to include in a document group.
2. Click Window > Create Document Group.
3. In the dialog box:

a) In Document Group Name, select a document group.
The software populates the list with the open files and the files saved under the
selected document group.

b) Click Create.
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7
Sketching

This chapter includes the following topics:

• Repairing Dangling Relations
• Flip Endpoint Tangent (2025 SP1)
• Linear and Circular Sketch Patterns

Repairing Dangling Relations

In the Display/Delete Relations PropertyManager, you can use Find Replacement to fix
dangling relations in a sketch. Use Repair All Dangling to automatically fix all dangling
relations.

You can use Auto Repair Sketch Relation or Dimension to repair the selected
dangling relation from the context toolbar.

These options are available only for 2D sketches. Dangling relations that have external
references cannot be repaired using Repair All Dangling and Find Replacement. You
must manually repair these dangling relations.
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To repair dangling relations:

1. Open a model that has a dangling relation.

2. Click Display/Delete Relations (Dimensions/Relations toolbar) or Tools >
Relations > Display/Delete.

3. In the PropertyManager, under Relations, select a dangling relation.
4. Under Entities, click Find Replacement.

SOLIDWORKS® searches for a replacement. A message appears if a replacement is
not found.

Repair All Dangling and Find Replacement are available when a sketch has
dangling relations.

5. When a replacement is found, review the replacement listed in Entity to replace
the one selected above and then click Replace.

Flip Endpoint Tangent (2025 SP1)

You can flip the endpoint of a tangent arc that is connected to a line. The radius of the
arc does not change.

The functionality is not available for 3D sketches.

To flip the endpoint of a tangent arc:

1. Open a new sketch and sketch a line.

2. Click Tangent Arc and create an arc from the end point of the line.
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3. Right-click the point where the arc and the line meet, and click Flip Endpoint Tangent

.

The tangent arc flips position:
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Linear and Circular Sketch Patterns
For linear and circular patterns, you can generate a fully defined sketch pattern.

For a linear sketch pattern of a fully defined entity, select these options in the Linear
Pattern PropertyManager to generate a fully defined pattern:

• Dimension X spacing
• Fix X-axis
• Dimension Y spacing
• Dimension angle between axes

For a circular sketch pattern, a coincident relation is applied automatically between a
selected point and the center of the pattern when the origin point is not the selected
point.
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8
Parts and Features

This chapter includes the following topics:

• Defeature Silhouette Method for Parts
• Patterning Reference Geometry
• Converting Mesh BREP to Standard BREP
• Segment Mesh Enhancements
• Move/Copy Body Features
• Variable Size Fillets
• Curve Through XYZ Points Enhancements

Defeature Silhouette Method for Parts

For single body and multibody parts, you can use the Silhouette defeature method to
create a highly simplified part and make it associative to the parent part.

In previous releases, the Silhouette defeature method was available only for assemblies.
You define groups of bodies and then define a simplification method for these groups.

Simplification methods include:

• Bounding Box
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• Cylinder
• Polygon Outline
• Tight Fit Outline
• None (Copy Geometry)

You can retain a link to the original model so if you update the original, the defeatured
model is updated. In the Results PropertyManager tab, when you select Create a new
configuration, in the ConfigurationManager, you can right-click the defeature
configuration and select Edit Defeature or Update Defeature.

To access the Silhouette defeature method, in a part, click Tools > Defeature and under

Defeature Method, click Silhouette .

Click or to navigate the modes and finalize the defeature process.

Patterning Reference Geometry

You can create linear or circular patterns of planes and axes.

To pattern reference geometry:

1. Open a part, click Insert > Pattern/Mirror, and select Linear Pattern or Circular
Pattern.

2. In the PropertyManager, select Reference Geometry.

3. For Reference Plane or Reference Axis to Pattern , select the plane or axis to
pattern.

4. Specify the parameters, then click .

You can modify the spacing and instance parameters for Direction 1 and Direction 2.
You can skip, vary, and delete instances.
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Limitations:

• If a plane contains a sketch, the plane pattern does not pattern the sketch.
• A pattern can contain one reference geometry entity only, either one plane or one
axis.

Converting Mesh BREP to Standard BREP

You can use the Convert Mesh to Standard tool to convert mesh BREP faces with
recognized geometry to standard BREP faces.

This functionality works for mesh BREP or hybrid mesh bodies that have recognized
geometry. The functionality works best for meshes with well-defined planar, cylindrical,
conical, and spherical geometry that do not have significant noise.

Benefits: Standard BREP geometry is more functionally complete than mesh or hybrid
geometry.

To convert mesh BREP with recognized faces to standard BREP:

1. Open a model that has mesh BREP or hybrid mesh bodies with segmented and
recognized faces.

This meshed model has been segmented into cylindrical, spherical, and planar faces.
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2. Do one of the following:

• Right-click a body and select Convert Mesh to Standard .

• Click Insert > Mesh > Convert Mesh to Standard .

• Click Convert Mesh to Standard (Mesh Modeling CommandManager).

3. In the PropertyManager, under Select Body, select bodies to convert segmented,
recognized mesh BREP faces to standard BREP faces.

Colors indicate faces that are recognized or unrecognized. You can specify these
Recognized mesh face and Unrecognized mesh face colors in Tools > Options
> System Options > Colors > Color scheme settings.

This entire model is recognized as one Convert Mesh to Standard feature, shown
as a green Recognized mesh face, as indicated in the legend in the lower-right
corner of the graphics area.
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4. Click to convert the recognized segmented mesh BREP faces to standard BREP
faces.

The converted standard BREP faces appear in the FeatureManager® design tree with

the Convert to Standard BREP name and icon .
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Segment Mesh Enhancements

The Segment Mesh tool recognizes additional face types and has an improved user
interface.

Additional Face Types Recognized

When you segment meshes, the software can recognize faces that are conical or spherical,
in addition to planes and cylinders. You can convert these recognized faces to standard
BREP faces with the same geometric condition.

Improved User Interface

In the Segment Mesh PropertyManager, under Segmenting, the Facet Shape tool
is available. This tool creates segments by grouping adjacent facets based on the shape
difference, which typically indicates a boundary between two regions in the model used
to create the mesh file.

Under Options, select Show Preview to preview the edges for segmented faces, shown
as yellow. Under Perimeter, drag to adjust the value to refine the segmentation of faces.
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When you run the Segment Imported Mesh Body tool, improved graphical information
helps you understand which faces have been recognized.

If you have not previously segmented the model, the display of mesh BREP bodies and
hybrid mesh bodies does not change.

• Standard BREP and graphics bodies are optionally hidden.
• Selected faces are highlighted using the Selected Item 1 color specified in Tools >

Options > System Options > Colors > Color scheme settings.

After the first round of segmenting the model, the following display changes apply:

• A legend appears to explain the colors used for recognized and unrecognized faces.

• The software uses the Recognized mesh face and Unrecognized mesh face colors
specified in Tools > Options > SystemOptions > Colors > Color scheme settings.

Move/Copy Body Features

TheMove/Copy Body feature offers enhanced support for equations and configurations.

In the Move/Copy Body PropertyManager, you can use equations to specify values for

the Distance dimension under Translate and for the Angle dimension under
Rotate. In the PropertyManager, enter = and the equation. For example, enter =20+50.
To access this equation in the Equations, Global Variables, and Dimensions dialog box,
in the FeatureManager design tree, right-click Equations and selectManage Equations.
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The Distance and Angle dimension icons are replaced with the icons and .
To flip the dimensions along the entity you selected, under Translate, click Distance

or under Rotate, click Angle .

You can use configurations to specify the values for all dimensions, including these

equation-driven values. This Configuration , All Configurations , and Specify

Configurations .

Variable Size Fillets

For variable size fillets, you can create continuously blended fillets with the Continuous
edge blend option.

To access this option, in the Fillet PropertyManager, for Fillet Type, select Variable Size

Fillet and under Fillet Options, select Continuous edge blend.

This option uses an improved algorithm to create continuously blended edges that are
extremely smooth.
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Curve Through XYZ Points Enhancements

The Insert > Curve > Curve Through XYZ Points functionality uses a PropertyManager
in which you can select a different coordinate system. The points of the curve transform
into the space of the coordinate system.

In earlier releases, this functionality used a dialog box and could only use the origin of
the part for the curve.

In the PropertyManager, you can:

• Manually enter the XYZ coordinate data.
• Click Browse to select a .sldcrv or .txt file.
• Click Reload to update the curve based on any modifications made to the .sldcrv
or .txt file used to create it.

When you open files created before SOLIDWORKS 2025 and edit curves created by XYZ
points, in the PropertyManager, under Reference Coordinate System, the software

uses the origin for Coordinate System (Origin) .
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9
Sheet Metal

This chapter includes the following topics:

• Bend Notches
• Tab and Slot
• Multi Length Edge Flanges and Automatic Flange Length Dimensions
• Performance Improvements in Cosmetic Thread Features
• Performance Improvements in Rebuilding Drawings

Bend Notches

You can create notches across bends in flattened sheet metal parts. In manufacturing,
bend notches help manufacturers determine where to put the press brake. You can use
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notch features on all bends so the bending operator can then use them to line up the
bend with the tooling.

Creating Bend Notches

You can create bend notches on sheet metal parts in the flattened state.

To create bend notches:

1. In a flattened sheet metal part, click Bend Notch (Sheet Metal toolbar) or Insert
> Sheet Metal > Bend Notch.

2. In the graphics area, select the bends where you want to add notches.

3. In the PropertyManager, specify options and click .

The notches appear in the flattened sheet metal part. You can edit the notches only
when the part is flattened.

BentFlattened
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Bend Notch PropertyManager

To open this PropertyManager:

1. In a flattened sheet metal part, click Bend Notch (Sheet Metal toolbar) or Insert
> Sheet Metal > Bend Notch.

Bend Notch

Lists the bends to apply notches to.Bends

Selects all bends in the part to apply notches to.Collect all bends

Specifies the notch shape:

• Triangular. Specify the Width and Depth .

• Circular. Specify the Radius .

• Rectangular. Specify the Width and Depth .

Notch type
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Tab and Slot

The workflow for creating tab and slot features is simplified and provides more flexibility.
Additional options let you create center-aligned tabs, offset tabs in equal increments, tab
directions, and instances of tab and slot features to skip.

After you select the tab edge in a sheet metal part, SOLIDWORKS® automatically selects
a slot face that is normal to the edge to streamline the process. For non-sheet metal
parts, you need to select the slot face.

If you have nonintersecting regions of two bodies, the tab and slot feature applies only
to the intersecting regions.

Tab and Slot PropertyManager

Spacing

Places the tabs from the center of the intersecting edge.

Specify the Number of Instances and Spacing
to define the number of instances based on the distance.

Center Align

Offset

Specifies the point, vertex, or edge where the offset begins.Tab Start
Reference

Specifies the point, vertex, or edge where the offset ends.Tab End
Reference
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Creates an offset where the start and end distance is the
same from the reference points.

Equal Offset

Tabs

(Non-sheet metal parts only.) Creates the tab in a direction
other than normal to the tab face based on your selection
in the graphics area.
You can select points, planes, edges, axes, vertices, linear
sketch entities, or planar faces.

Tab Direction

Instances to Skip

Skips the tab and slot instances that you select in the
graphics area.
In the graphics area, pink selection orbs display on the

tab and slot instances. The pointer changes to when
you hover over each instance and the coordinates of the
instance appear. Click a selection orb.

To restore a skipped instance, click the selection orb again.

Instances to Skip

Multi Length Edge Flanges and Automatic Flange Length Dimensions
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When you create edge flanges in sheet metal parts, you can create flanges with different
lengths.

In the PropertyManager, you can select Multi Length Flange and specify the length of

each flange in the feature. You can specify the Length in the PropertyManager or in
the graphics area.

In Tools > Options > Document Properties > Sheet Metal, under Edge Flange
Options, you can select Automatically add Flange Length dimension to flange
profiles.

When selected:

• SOLIDWORKS automatically adds length dimensions to all edge flange profiles
• The sketch dimension (not the feature dimension) controls the flange length
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Performance Improvements in Cosmetic Thread Features
You can experience improved performance while working with multibody parts with a
large number of cosmetic thread features when you enable the Shaded cosmetic threads
option.

For sheet metal parts with multiple cosmetic thread features, performance is improved
for these operations:

• Opening parts
• Creating new features
• Editing features
• Updating and rebuilding parts

Performance Improvements in Rebuilding Drawings
Performance is improved while working with drawings that contain drawing views of sheet
metal parts with many holes and forming tools.

When working with such drawings, you can experience improved performance for:

• Opening drawing files
• Making new drawings from the sheet metal part
• Updating drawing views after making edits to the sheet metal part
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10
Structure System and Weldments

This chapter includes the following topics:

• Accessing and Working with Favorite Profiles
• Complex Corner PropertyManager and Structure System
• Trimming Attached Members
• Groove Beads

Accessing and Working with Favorite Profiles

You can add favorite profiles in the Primary Structural Member and Secondary Structural
Member PropertyManagers for quick access.

To access and work with favorite profiles:

1. Open a structure system part and click the Structure System tab.
2. In the CommandManager, click Create Structure System.
3. In the Primary Structural Member PropertyManager, on the Profile tab, select the

Standard, Type, and Size of the profile.

4. Click Add to Favorites to add the profile as a favorite profile.

as a suffix to the size indicates a favorite profile.
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5. On the Member tab, under Profile, select the profile in Favorite Profiles.

6. Click to modify the list of favorite profiles.
7. In the Favorite Profile List dialog box, select a profile and click the following:

• OK. Accepts the changes, if any.
• Delete. Deletes the selected profile.
• Move Up or Move Down. Changes the sequence of profiles in the list.

Complex Corner PropertyManager and Structure System
The Complex Corner PropertyManager provides enhanced Corner Treatment options.
Also, you can create and edit the structure system more easily.

Complex Corner PropertyManager

To open this PropertyManager:

1. Open a model that includes three or more intersecting members.

2. In the FeatureManager® design tree, expand Corner Management .
3. Right-click Complex Corner Group and select Edit Feature.

Enhancements include:

• Under Corner Treatment, the members box displays body trim members and planar
trim members. You can select a member and click Body Trim or Planar Trim to
change its trim type.

• Details of the selected member, such as body trim, planar trim, and trim order appear
as callouts in the graphics area.

• Icons represent planar trim options.
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Access to Structure System
Enhancements include:

• When you open a structure systemmodel, SOLIDWORKS displays a message to activate
the Structure System tab.

• For new files, the CommandManager displays Create Structure System. When you
click Create Structure System, SOLIDWORKS displays Primary Member
PropertyManager.

• For files that include a structure system, the CommandManager displays Edit Structure
System.

• For files that include multiple structure systems, you must select the structure system
to edit from the FeatureManager design tree.

Trimming Attached Members

You can trim an attached member when you insert a connection element.

In the Insert Connection Element PropertyManager, Trim attached member trims the
body member from its intersection point with the connection element.

To trim attached members:

1. Open a structure system model and click the Structure System tab.
2. Click the Insert Connection Element tab on the CommandManager or Insert >

Structure System > Insert Connection Element .
3. Select the connection element to insert.
4. In the PropertyManager, click the Placement tab.
5. In the graphics area, select the reference entities.
6. Select the alignment.
7. Under Cut Scope, select Trim attached member.
8. Click .
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Trim attached member clearedTrim attached member selected

Groove Beads

You can create a groove bead to join two selected surfaces with a solid weld.
SOLIDWORKS® creates a solid body in the gap based on the surfaces.

Creating Groove Beads

You can create groove beads between the two surfaces.

To create groove beads:

1. Open a part that has solid bodies to join.

62

Structure System and Weldments



2. Click Insert > Weldments > Groove Bead.
3. In the graphics area, select the faces to join.
4. Specify options in the PropertyManager and click .

Groove Bead PropertyManager

The Groove Bead PropertyManager lets you create a solid weld between two solid bodies.

To open this PropertyManager:

1. Open a multibody part and click Insert > Weldments > Groove Bead.

Face Selections
Face set 1 and Face set 2. Specifies the faces of solid bodies to connect from the graphics
area.

Full face weld
Creates a weld on the entire surface. Otherwise, creates a weld on the surface where one
surface projects on another.

Full face weld clearedFull face weld selected

Radial Fill
Creates a weld on the surface including the radial fill distance.
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Radial Fill clearedRadial Fill selected

Define Weld Symbol
Opens the Weld Symbol dialog box to define the weld symbol settings. The weld symbol
attaches to the active weld bead.

See Weld Symbol Properties.
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11
Assemblies

This chapter includes the following topics:

• Assembly Visualization
• SpeedPak Instances
• Interference Detection in Large Design Review Mode
• Canceling Interference Detection Calculations (2025 SP1)
• Performance Evaluation
• Linking Display State to the Patterned Seed Component
• Inserting Assemblies with Rolled-Back Features
• Copy with Mates
• Maintaining External References to Derived Sketches (2025 SP1)
• Warning When Moving Components (2025 SP1)
• Performance When Calculating Mass Properties
• Controlling the Visibility of Part Sketches in Assemblies

Assembly Visualization
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You can assign a color to a property value, select new properties, and roll up or roll down
components.

In the Custom Column dialog box, you can select Link color to property value to specify
a color for a component property. When you select this option, you cannot change the
colors using the color slider.

In the context toolbar for a component, you can use Roll up component and Roll down
component to hide components.

In the Custom Column dialog box, these properties are available:

The 3DEXPERIENCE properties are available on the 3DEXPERIENCE platform. For these
properties, Link color to property value is always selected.

DescriptionProperty

Reports whether the component has an
envelope component.

Envelope Component

Reports whether the component has
overridden mass properties.

Overridden Mass Properties

Reports the CAD format of the component.
Examples of CAD formats:

• 3DEXPERIENCE®

• CATIAV5
• X-CAD
• SOLIDWORKS®

3DEXPERIENCE - CAD Format

Reports the collaborative spaces where the
component is saved.

3DEXPERIENCE - Collaborative Space

Reports whether this is the latest revision
of the component.

3DEXPERIENCE - Latest Revision

Reports the lock status of the component:
• Locked by me
• Locked by other user
• Not locked

3DEXPERIENCE - Lock status
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DescriptionProperty

Reports the maturity level of the
component:
• Frozen
• In Work
• Obsolete
• Private
• Released

3DEXPERIENCE - Maturity

Reports whether the component is updated
for compatibility with the 3DEXPERIENCE
platform.

3DEXPERIENCE - Updated for
compatibility

To link a color to a property value:

1. Open a model that contains components with overridden mass properties.

2. Click Assembly Visualization (Tools toolbar or Evaluate tab on the
CommandManager) or Tools > Evaluate > Assembly Visualization.

3. On the Assembly Visualization tab, click the arrow to the right of the column headers.

4. Click More.
5. In the Custom Column dialog box, under Properties, select a property like

Overridden Mass Properties.
6. Select Link color to property value.
7. Double-click Type a new value and enter a value.
8. Click Edit Color and select a color for the value.
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9. After closing the dialog boxes, on the Assembly Visualization tab, click the Overridden
Mass Properties column header to sort the column by values.
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SpeedPak Instances

You can create a SpeedPak instance from a subassembly without modifying the referenced
subassembly. The SpeedPak instance is saved in the top-level assembly.

You can edit a SpeedPak instance by right-clicking the instance and clicking SpeedPak
Options > Edit SpeedPak.

Inserting a SpeedPak Instance

You can create a SpeedPak instance by adding an assembly to the model.

To insert a SpeedPak instance:

1. Open a model and click Insert > Component > Insert SpeedPak Instance .

Insert SpeedPak Instance is not available in Large Design Review mode.

2. In the PropertyManager, select an assembly to insert and specify options.

3. Click Next to open the SpeedPak PropertyManager and specify SpeedPak options.

The SpeedPak instance shows in the FeatureManager® design tree.

Creating a SpeedPak Instance

You can create a SpeedPak instance from a subassembly that is in the model.

To create a SpeedPak instance:

1. Open a model that has subassemblies.
2. Right-click a subassembly and click SpeedPak Options.
3. Select an option: Create Mated SpeedPak or Create Graphics SpeedPak.
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4. When prompted, select Create a SpeedPak Instance in the top level assembly.

The SpeedPak instance appears in the FeatureManager design tree.

Switching Between a SpeedPak Instance and a Parent Subassembly

To switch between a SpeedPak instance and a parent subassembly:

1. In the FeatureManager design tree, right-click the SpeedPak instance and click
SpeedPak Options > Set SpeedPak to Parent.

2. Optional: To switch back to the SpeedPak instance, right-click the subassembly and
click SpeedPak Options > Use SpeedPak.

Interference Detection in Large Design Review Mode

You can use interference detection on assemblies opened in Large Design Review mode.

In Large Design Review mode, the volume of interference is not available and
calculations for interference detection are approximate. For accurate results, resolve
the components and recalculate the interferences.

To use interference detection in Large Design Review mode:

1. Open an assembly in Large Design Review mode.

2. Click Interference Detection (Large Design Review tab) or Tools > Evaluate
> Interference Detection.

3. Select options in the PropertyManager and click Calculate.
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The following options are unavailable in the PropertyManager:

• Create fasteners folder
• Create matching cosmetic threads folder
• Excluded Components
• Hide excluded components from view
• Ignore all smaller than
• Ignore hidden bodies/components
• Include surface bodies
• Remember excluded components
• Sort Largest to Smallest
• Sort Smallest to Largest
• Treat coincidence as interference

Canceling Interference Detection Calculations (2025 SP1)

You can cancel calculations for interference detection.

To cancel interference detection calculations:

1. Open a large model.

2. Click Interference Detection (Assembly toolbar) or Tools > Evaluate >
Interference Detection.

3. In the PropertyManager, click Calculate.
4. Click Cancel in the dialog box or press Esc.
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Performance Evaluation

In the Performance Evaluation dialog box, you can see the number of outdated documents,
the time required to open the assembly, and the total number of graphics triangles.

New options and information:

SectionDescriptionOptions and
Information

Open
Performance

Under Open Summary, displays the time taken
to open the assembly.

Time to open

Open
Performance

Lists the number of documents found in the
Referenced Documents folders and the time
taken to perform the search.

Searching for
Referenced
Documents

Display
Performance

Under Graphics Triangles Details, displays
the total number of graphic triangles in the
top-level assembly.

In the number, SOLIDWORKS uses the separator
specified by the operating system to separate
groups of thousands.

Total number of
triangles in the
assembly
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SectionDescriptionOptions and
Information

Display
Performance

Under Shaded Image Quality, reduces the
shaded image quality to 50% for the parts with
higher image quality.

This option does not apply to subassemblies.

Not available for assemblies opened in
lightweight mode except when the assembly
has a flexible subassembly.

Clicking Reduce Image Qualitymoves the Low
(faster) - High (slower) slider closer to the
Low (faster) side.

To view the slider, click Tools > Options >
Document Properties > Image Quality. The
slider is under Shaded and draft quality
HLR/HLV resolution.

Reduce Image
Quality

Rebuild
Performance

Under Mate, displays the time required to solve
the mates when you rebuild the assembly.

Time to solve mates

Rebuild
Performance

You can use Open and Isolate Components
in the Mates dialog box.

UnderMate, click Show These Files to open
the dialog box.

Open and Isolate
Components

Rebuild
Performance

Lists the number of mates in the flexible
subassemblies.

Flexible
subassemblies

Rebuild
Performance

Lists parts with more than 20 configurations that

have the Rebuild on Save mark .

Configurations
Rebuilt on Save

StatisticsUnder Assemblies, the statistics do not include
suppressed mates.

Statistics

To use performance evaluation:

1. Open an assembly.

2. Click Performance Evaluation (Evaluate toolbar) or Tools > Evaluate >
Performance Evaluation.

To reduce the image quality:

1. Open a model and click Tools > Options > Document Properties > Image Quality.
2. Review the slider position under Shaded and draft quality HLR/HLV resolution.
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3. Click Tools > Evaluate > Performance Evaluation.
4. Under Shaded Image Quality in the Display Performance section, click Reduce

Image Quality .

5. After the Performance Evaluation results update, check the slider position under
Shaded and draft quality HLR/HLV resolution.

Linking Display State to the Patterned Seed Component

74

Assemblies



You can link the display state of the patterned components to the patterned seed
component.

Use the following options in the Component Properties dialog box to select the display
state:

Links the display state of the patterned
components to the patterned seed component.
Disables the list of display states.

Use same Display State as pattern
seed component

Shows the list of display states.
This option is available when the patterned
component references a different configuration
for the patterned seed component and the display
type is a linked display state.

Use named Display State

You can link the display state in any Component Pattern PropertyManager. In the
PropertyManager, under Synchronize configuration of patterned components to
seed, select Synchronize display states.

To link the display state to the patterned seed component:

1. Open a model that contains patterned components.
2. In the FeatureManager design tree, expand a patterned component.
3. Under the expanded patterned component, right-click a component and click

Component Properties .
4. In the dialog box, select Use same Display State as pattern seed component.

When Synchronize display states is selected in a Component Pattern
PropertyManager, Use same Display State as pattern seed component is
selected and cannot be cleared.

75

Assemblies



Inserting Assemblies with Rolled-Back Features

In a model, you can insert an assembly with a part reference that has rolled-back features.

To insert an assembly with rolled-back features:

1. Open a model and click Insert Components (Assembly toolbar) or Insert >
Component > Existing Part / Assembly.

2. Select an assembly that contains a part with rolled-back features.

The assembly is added to the model.

Copy with Mates
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You can use Copy with Mates to copy components that have a lock mate, a path mate,
a linear coupler mate, or a mechanical mate.

For hinge mates, you can copy a maximum of six hinge mates at the same time.

To copy with mates:

1. Open a model, and click Copy with Mates (Assembly toolbar) or Insert >
Component > Copy with Mates.

2. In the PropertyManager, select a component that has mechanical mates.

3. Click Next .

Under Mates, the mechanical mates are listed.

Maintaining External References to Derived Sketches (2025 SP1)

When you use Save As Copy and Continue to copy a part, external references to a
derived sketch in the copied part are maintained.

The external references are maintained when you use Microsoft® File Explorer to copy a
part with a derived sketch.

To maintain external references to derived sketches:

1. Open a model that contains two parts.

In this example, Part 1 shows in the graphics area.
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2. Create a derived sketch.

a. Right-click Part 2 and click Edit Part .
b. Press Ctrl and select a sketch from Part 1 and a plane from Part 2.

c. Click Insert > Derived Sketch.
d. Exit the edit-in-context mode by clicking in the confirmation corner.
e. Click File > Save All.

Part 2 has a derived sketch from Part 1.

3. Create a copy of the part that has the derived sketch.

a. Right-click Part 2 and click Edit Part .
b. Click File > Save As > Save as Copy and Continue.
c. Save the new part as Part 3.
d. Exit the edit-in-context mode.

4. Insert the new part into the model.

a. Click Insert > Component > Existing Part/Assembly.
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b. In the dialog box, select Part 3 and add the part.

Part 2 and Part 3 have the derived sketch.

5. Update the first part.

a. For Part 1, right-click the sketch and click Edit Sketch .
b. Modify a dimension.

A dimension in Part 1 changed from 200mm to 170mm.

c. Exit the edit-in-context mode.

Part 3 uses the updated dimension and the derived sketch remains defined.

79

Assemblies



Warning When Moving Components (2025 SP1)

When a component moves a long distance from an assembly, SOLIDWORKS shows a
warning message.

In some cases, a small drag of a component or changing mate settings can cause a
component to move far away from the assembly.

The long distance between the component and the assembly can cause issues with view

rotation and Zoom to Fit .

To return the component to the previous position, click Undo in the notification dialog

box or click Edit > Undo Move Component .
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Performance When Calculating Mass Properties
Performance is improved when calculating mass properties for an assembly.

Controlling the Visibility of Part Sketches in Assemblies

You can control the visibility of part sketches in assemblies.

SOLIDWORKS maintains the visibility of sketch display states when you insert a part into
an assembly. In earlier releases, the part took precedence over the sketch.

To control the visibility of part sketches in assemblies:

1. Create a part with two sketches.
2. Create two display states in the part.
3. Make the sketch visibility such that one sketch is visible in one display state and the

other sketch is visible in the other display state.
4. Insert two instances of the part in an assembly.
5. Make the sketch visibility such that each part display state is visible.

Each component shows the visibility of the sketch per its referred display state.
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12
Detailing and Drawings

This chapter includes the following topics:

• Inserting Family Tables in Drawings (2025 SP1)
• Creating Surface Finish Symbols in Conformance with ISO 21920 (2025 SP1)
• Linking Bills of Materials to Display States (2025 SP1)
• Bill of Materials Configuration Names (2025 SP1)
• Creating Flattened BOMs (2025 SP1)
• Auto-Generate Drawings (2025 SP1)
• Additional Tolerance Types for Chamfer Dimensions
• BOM Quantity Override for Detailed Cut Lists
• Performance Improvements in Drawings
• Reloading Drawings
• Exporting Drawing Views as Blocks to DXF/DWG Files
• Inserting and Viewing Cosmetic Threads in Assembly Drawings

Inserting Family Tables in Drawings (2025 SP1)
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You can use the Family Table tool to insert configuration data in drawings.

Benefits: You can quickly insert configuration data in drawings without needing any
workarounds. Family tables display variations in part and assembly configurations or
custom properties in a table in SOLIDWORKS drawings.

To insert family tables in drawings:

1. In a SOLIDWORKS drawing, click Insert > Tables > Family Table .
2. In the PropertyManager:

a. Select the file from which to create the family table and click Next .
b. Specify options to define the family table.

c. Click .

3. Click in the drawing file to place the table.

Creating Surface Finish Symbols in Conformance with ISO 21920 (2025
SP1)

You can insert surface finish symbols that comply with the latest ISO standards including
ISO 21920-1, ISO 1302:202, and ISO 1302:1992.

You can use the following symbols.
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21920-1

1302 (2002)

1302 (1992)

To create surface finish symbols in conformance with ISO 21920:

1. In a drawing, click Tools > Options > Document Properties > Annotations >
Surface Finishes.

2. In the dialog box in Surface symbol standard, select a standard and click OK.

Linking Bills of Materials to Display States (2025 SP1)
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In the Bill of Materials (BOM) PropertyManager, you can link a BOM to display states.

Benefits: You can see items in the BOM only for components that are visible in the view.

To link BOMs to display states:

1. In the Bill of Materials PropertyManager, under Configurations, select Link to
Display State.

2. Click and select a display state.

3. Click .

Bill of Materials Configuration Names (2025 SP1)

The option Show all configurations is renamed to Display configuration names. You
can access this option by right-clicking the quantity column (QTY.) in a bill of materials
(BOM).

When you link a display state to a BOM, the software displays the configuration name in
the QTY. column as Configuration name / QTY.
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Creating Flattened BOMs (2025 SP1)

In the Bill of Materials PropertyManager, you can flatten a BOM to display the total
quantities for all components.

Benefits: Flattened BOMs save time by calculating the total number of quantities of the
components.

The flattened BOM displays the:

• Model as a list of components without indentation.
• Component only once if it exists at multiple levels of the model.
• Total quantity of the component by adding the quantities of every component.

To create flattened BOMs:

1. In a drawing, click Bill of Materials (Table toolbar) or Insert > Tables > Bill
of Materials.

2. In the PropertyManager, for BOM Type select Flattened.

3. Click .
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Auto-Generate Drawings (2025 SP1)

You can auto generate drawings of parts and assemblies.

Benefits: Automatically generating drawings reduces errors and time spent on repetitive
tasks.

Auto Generating Drawings

You can automatically generate drawings of parts and assemblies.

To auto generate drawings:

1. Do one of the following:

• Click File > Auto-Generate Drawing.
• In the FeatureManager design tree or graphics area, right-click a part, subassembly,
or assembly, and click Auto-Generate Drawing.

2. Optional: To select multiple part or assembly components, do one of the following:

• In the FeatureManager design tree or graphics area, Ctrl + select components and
click File > Auto-Generate Drawing.

• In the Auto-Generate Drawings task pane, click Edit.

3. In the PropertyManager, specify options and click .

Auto-Generate Drawing PropertyManager

In the Auto-Generate Drawing PropertyManager, you can select components from parts
or assemblies to automatically generate a drawing.

To open this PropertyManager:

In a part or assembly, click File > Auto-Generate Drawing.
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Specifies the components to
include in the
auto-generated drawing.

Selected components

Specifies a title for the
auto-generated drawing.

Title

Resets the title of the
drawing to the part or
assembly file name.

Reset to filename

Specifies a folder to save the
auto-generated drawing.

Save location

Saves the auto-generated
drawing in the same folder
as the component selected
for the drawing generation.

Same as parent
part/assembly

Tasks (Auto-Generate Drawings) Tab

The Tasks (Auto-Generate Drawings) tab shows a list of generated drawings and their
progress. You can monitor the progress of these drawings tasks and take actions.

To open this tab:

In a part or assembly, select the Tasks (Auto-generate drawings) tool from the task
pane tab.

Displays the name of the
generated drawing.

Title
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Displays the status of the
drawing generation. The
status includes one of these
icons:
• In-progress

• Completed

•

• Failed

•

Status
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Displays actions that you can
perform:
• Cancel. (Available during
drawing creation.)
Cancels the auto-drawing
generation for the
selected item.

• Open. (Available when
the software completes
the drawing creation.)
Opens the selected
drawing in Detailed Mode.

• View Details. (Available
when the drawing
creation fails.) Opens the
report to show why the
auto-generated drawing
failed.

• Right-click any row in the
task tab to:

• Clear. Clears the
selected row from the
list.

• Clear All. Clears all
the rows from the task
tab, except for the
rows in progress. This
includes rows in which
the status is complete
or failed.

Actions
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Additional Tolerance Types for Chamfer Dimensions

You can specify MIN, MAX, Limit, Fit, and Fit with Tolerance tolerance types for
chamfer dimensions in drawings.

To access additional tolerance types for chamfer dimensions:

1. Click Tools > Options > Document Properties > Dimensions > Chamfer.
2. In the Document Properties - Chamfer dialog box, click Tolerance.
3. In the Chamfer Dimension Tolerance dialog box, in Tolerance type, select a tolerance

and click OK.
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BOM Quantity Override for Detailed Cut Lists

In the Bill of Materials PropertyManager, you can choose an option for Detailed Cut List
to use the BOM quantity in weldments.

When you select the option, Calculate quantity using BOM quantity, the software
takes the property that you select in the BOM quantity list and uses the value as the
multiplier. If you clear the option, the BOM table displays the quantity as the number of
instances.

To use the BOM quantity override for detailed cut lists:

1. Click Bill of Materials (Table toolbar) or Insert > Tables > Bill of Materials.
2. In the PropertyManager, select Detailed Cut List and Calculate quantity using

BOM quantity.

3. Click .
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Performance Improvements in Drawings
Drawings performance has improved with panning and zooming.

Reloading Drawings

You can reload SOLIDWORKS drawings. This is useful in multi-user environments if you
have read-only access and want the latest version with changes made by another user.

This enhancement was first included in SOLIDWORKS 2024 SP2 but not fully documented
at that time. We include it here to promote full customer awareness of the enhancement.

Benefits: You can share the latest version of files with other users.

To reload drawings:

1. In a drawing, click File > Reload.

Exporting Drawing Views as Blocks to DXF/DWG Files
You can export drawing views as blocks to .dxf or .dwg files.

This enhancement was included in SOLIDWORKS 2024 SP2 but not fully documented
at that time. We include it here to promote full awareness of the enhancement.

Benefits: Grouping related geometry into blocks helps organize drawings and makes it
easier to navigate and manage complex designs.

To export drawing views as blocks to DXF/DWG files:

1. In a drawing, click Tools > Options > System Options > Export.
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2. Under File Format, select DXF/DWG.
3. Click OK.

Inserting and Viewing Cosmetic Threads in Assembly Drawings

You can insert and view cosmetic threads in assembly drawings.

This enhancement was first included in SOLIDWORKS 2024 SP2 but not fully documented
at that time. We include it here to promote full customer awareness of the enhancement.

Benefits: You have more control over whether or not you want to insert and view cosmetic
threads in assembly drawings.

Previously, when you inserted cosmetic threads into assembly drawings, you did not see
the cosmetic threads. You had to click Insert >Model Items every time in the assembly
drawing to display cosmetic threads.

To insert cosmetic threads into assembly drawings:

1. Click Tools > Options > Document Properties > Detailing.
2. Under Auto insert on view creation, select Cosmetic Threads - assembly (may

affect performance), and click OK.

To view cosmetic threads in assembly drawings:

1. In the Drawing View PropertyManager, under Import options, select Import
annotations and Cosmetic threads.

2. Click .
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13
Configurations

Display State Tables

In assemblies with multiple display states, you can use the Display State Table to control
the display states.

The Display State Table lets you:

• Control the Hide/Show state of a component
• Add a new display state by clicking in the Creates a new display state column
• Add a new component to the table by double-clicking the component in the
PropertyManager or graphics area

• Double-click a display state's name cell to switch to that display state
• Right-click a display state's name cell to rename the display state or switch to it
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To access the display state table, in the ConfigurationManager , under Display States

> Tables , right-click Display State Table and click Show Table.

General Information

• The table appears if the top-level assembly contains more than one display state.
• The table is available for unlinked and linked display states. For linked display states,
the table shows the display states that are available for the active configuration.

• In the table, you can click Hide/Show Referenced Display State to hide or show
the Referenced Display State row for each component in all top-level display states.
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14
Import/Export

This chapter includes the following topics:

• Exporting Custom Properties to IFC Files
• Importing Extended Reality Files

Exporting Custom Properties to IFC Files

When you export SOLIDWORKS®models as IFC™ files, you can map SOLIDWORKS custom
properties to IFC property sets.

To export custom properties to IFC files:

1. In Tools > Options > System Options > Export, under File Format, select IFC.
2. Under Output as, select Use Property Set mapping file.
3. Then specify the XML Schema or .xsd mapping file that the software uses to validate

the exported properties.

Benefits: BIM customers can export their custom properties data, which is important for
the construction and operation of the building. This functionality is flexible. It lets you
map SOLIDWORKS properties to IFC properties, potentially with a different name, and
to define your own target property sets in the IFC file. In previous releases, you could
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export properties when you saved as IFC files, but only to a single hard-coded property
set in the IFC file.

To export custom properties to IFC property sets:

1. In the SOLIDWORKS file, click File > Properties.
2. On the Custom tab, add properties that you want to export to the IFC file and save

the file.
3. Create an XML mapping file that maps the SOLIDWORKS custom properties to the

IFC property set values.

SOLIDWORKS offers sample mapping files at SOLIDWORKS install
folder\lang\language\IFC.

Sample mapping file:

<CustomPropertiesPSETMapping>
<Schema Version="1.0"/>
<PropertySet Name="Pset_DoorCommon">

<AppliesTo ElementType="IFCDOOR"/>
<PropertyMapping SOLIDWORKS="Reference" IFC="Reference"

Type="IfcIdentifier"/>
<PropertyMapping SOLIDWORKS="FireRating" IFC="FireRating"

Type="IfcLabel"/>
<PropertyMapping SOLIDWORKS="NoiseRating" IFC="AcousticRating"

Type="IfcLabel"/>
<PropertyMapping SOLIDWORKS="Security" IFC="SecurityRating"

Type="IfcLabel"/>
<PropertyMapping SOLIDWORKS="External" IFC="IsExternal"

Type="IfcBoolean"/>
<PropertyMapping SOLIDWORKS="Infiltration" IFC="Infiltration"

Type="IfcVolumetricFlowRateMeasure"/>
<PropertyMapping SOLIDWORKS="ThermalTransmit"

IFC="ThermalTransmittance" Type="IfcThermalTransmittanceMeasure"/>
<PropertyMapping SOLIDWORKS="Glazing"

IFC="GlazingAreaFraction" Type="IfcPositiveRatioMeasure"/>
<PropertyMapping SOLIDWORKS="Accessible"

IFC="HandicapAccessible" Type="IfcBoolean"/>
<PropertyMapping SOLIDWORKS="FireDoor" IFC="FireExit"

Type="IfcBoolean"/>
<PropertyMapping SOLIDWORKS="StarTrekDoor" IFC="SelfClosing"

Type="IfcBoolean"/>
<PropertyMapping SOLIDWORKS="SmokeStop" IFC="SmokeStop"

Type="IfcBoolean"/>
</PropertySet>
<PropertySet Name="ACME_CageCodes">

<AppliesTo ElementType="IFCDOOR"/>
<AppliesTo ElementType="IFCWINDOW"/>
<PropertyMapping SOLIDWORKS="RefCode" IFC="CageCode"

Type="IfcLabel"/>
</PropertySet>

</CustomPropertiesPSETMapping>

4. In the SOLIDWORKS file, click Save As (Standard toolbar) or File > Save As.
5. In the dialog box, for Save as type, select the IFC file type, then click Options.

You can select any IFC file type.
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6. In the System Options dialog box, under Output as, select Use Property Set
mapping file, and select the mapping file from the list or browse to select it.

To include all the custom properties from the SOLIDWORKS file in the exported IFC
file, under Output as, also select Custom Properties. To include these in the IFC
property set, map all the custom properties in the XML Schema file.

SOLIDWORKS checks the validity of the XML IFC property set for these items:

• Proper tags, tag attributes, and tag structure.
• The Schema Version is equal to or lower than the version supported by the current
version of SOLIDWORKS.

• SOLIDWORKS custom properties map one-to one or one-to-many IFC properties.
You cannot map multiple SOLIDWORKS custom properties to the same IFC property.

The software stores up to 10 property sets in the registry.

7. Click OK then click Save to export the file as an IFC file.

The IFC file contains the SOLIDWORKS custom properties in the IFC property set,
based on the XML Schema mapping file.

Importing Extended Reality Files

You can import the extended reality file types .glTF and .GLB.

To import extended reality files:

1. Click Open (Standard toolbar) or File > Open.
2. In the dialog box, for Files of Type, select Extended Reality (.*GLTF and .GLB).
3. Browse to select a file and click Open.

Importing glTF™ and GLB files includes:
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• Geometry hierarchy of the imported glTF or GLB file.
• Draco™ compression.

This is a compression option for large-sized files. You do not specify any options on
import. The file owner specifies the Draco compression on export of the glTF or GLB
files from the source software.

• Noneditable textures. The software imports textures but not as proper SOLIDWORKS
appearances.
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15
SOLIDWORKS PDM

This chapter includes the following topics:

• Default Settings for Computed BOM
• Checking Out Files During the Get Operation
• Logging Information for User Authentication
• Opening File Data in Microsoft Excel with Thumbnails
• Viewing the FeatureManager Design Tree Order of Assembly Structure in Computed

BOMs
• Getting Information on Time Taken in Opening Files
• Getting Information on the Latest Revision
• Separate Add or Rename Permissions for Files and Folders
• SOLIDWORKS PDM to Electrical Connector
• File Check in Performance
• Availability of SOLIDWORKS PDM Toolbar and CommandManager Tab
• Additional Options in the Task Pane Shortcut Menu and Toolbar
• Support for SSL or TLS Authentication in SMTP Email Notification
• Display Options - Show Image Preview (2025 SP1)
• Card Controls Options (2025 SP1)
• Configuring the Convert Task (2025 SP1)
• Search Favorites (2025 SP1)
• Electrical Assembly Bill of Materials (2025 SP1)

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional, SOLIDWORKS Premium, and SOLIDWORKS Ultimate, and is
available as a separately purchased license for non-SOLIDWORKS users. It offers standard
data management capabilities for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Default Settings for Computed BOM

Administrators can specify the default view and options settings for the computed BOM
while creating the Bill of Materials (BOM) in the SOLIDWORKS PDM Administration tool.

The default settings that the administrators specify apply to the BOM View and Options
sections under the Bill of Materials tab in the SOLIDWORKS PDM File Explorer. The default
settings are applicable to both the desktop and the Web2 client.

In the Administration tool, right-click Bill of Materials > New Bill of Materials. In the
Bill of Materials - New Bill of Materials dialog box, under Default Settings, specify the
default settings for the computed BOM.
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Checking Out Files During the Get Operation

In the SOLIDWORKS PDM File Explorer, you can check out files while performing a Get
operation on them, for example, Get Latest Version, provided you have checkout
permission granted.

In the Get dialog box, when you select Check Out for single or multiple files, the Get
option for these files is selected by default to perform both the operations at the same
time. The combined Get and Check out operation simplifies your workflow.

You can add the Check out column in the Get dialog box of SOLIDWORKS PDM File
Explorer. The customization is done using the Customizable Columns view for Get file
operations columns in the SOLIDWORKS PDM Administration tool.

The following conditions apply for the combined Get and Check out operation:

• If the get operation fails, checkout does not proceed.
• If checkout fails, the get operation still proceeds.
• When running the get operation for an older version, if you select Check out, you get
the specified version with a checkout performed.

103

SOLIDWORKS PDM



Logging Information for User Authentication

You can view the user authentication details for a vault in the SOLIDWORKS PDM
Professional Administration tool.

The authentication details include the user name, the date, and time when the user has
logged in and out, and the SOLIDWORKS PDM client (desktop or Web2).

You can right-click the vault name and select Logs > Show the Log-in and Log-out
Log to view the authentication details. To see this option, you must have:

• A SOLIDWORKS PDM Professional vault.
• File Vault Management permission.
• The Log-in and Log-out option selected in the file vault properties under Logging

Operations.
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Opening File Data in Microsoft Excel with Thumbnails

You can open the file data in the Microsoft® Excel® format along with a thumbnail preview
in the Bill of Materials, Contains, and Where Used tabs of the SOLIDWORKS PDM File
Explorer.

You can open file data with thumbnails using Open All With Thumbnails and Open

Visible With Thumbnails under Open as CSV in the toolbar of the tabs.

With thumbnail preview, you can understand the data more clearly and you can effectively
communicate the process outside the vault.

Viewing the FeatureManager Design Tree Order of Assembly Structure in
Computed BOMs

You can view the order of the assembly structure in the computed BOMs of the
SOLIDWORKS PDM File Explorer for newly checked in files. The view is similar to that in
the SOLIDWORKS FeatureManager® design tree.

The order of assembly components in the BOM for data already checked in to the vault
does not change to match with the FeatureManager design tree.
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Getting Information on Time Taken in Opening Files

You can know the time taken to open a file when it was last opened in SOLIDWORKS
2023 and above. The time is measured in seconds. To know the file open time, a new
variable _SW_Last_Open_Time_ is added to the SOLIDWORKS PDM variables.

Getting Information on the Latest Revision
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You can get the latest revision for a file in SOLIDWORKS PDM. For getting the latest
revision, a Latest Revision variable is added to the existing system variables.

To retrieve the revision information for a file, you can use the Get Latest Revision

and Get Revision commands in the SOLIDWORKS PDM File Explorer at different
places such as during searching files, in right-click menu of a file view, the Version tab,
and the Column Sets. You can also use these commands in the SOLIDWORKS PDM add-in
toolbar and CommandManager.

Separate Add or Rename Permissions for Files and Folders
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The existing Add or rename file and Add or rename folder permissions are split into
separate permissions for add and rename.

Administrators can use Add file and Rename File under Folder Permissions and State
Permissions in the SOLIDWORKS PDM Administration tool.

SOLIDWORKS PDM to Electrical Connector

The SOLIDWORKS Electrical to SOLIDWORKS PDM connector is available with the
SOLIDWORKS PDM install. It is integrated with SOLIDWORKS PDM and is not available
as a SOLIDWORKS PDM add-in.

You can configure the SOLIDWORKS Electrical connector from the SOLIDWORKS PDM
Administration tool. A SOLIDWORKS Electrical node is added under the SOLIDWORKS
PDM vault for the configuration.
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The History option is added to the SOLIDWORKS PDM CommandManager options. You
can see the history of SOLIDWORKS Electrical projects using this option for better
monitoring of the changes.

File Check in Performance
SOLIDWORKS PDM performance is improved during the file check in to the SOLIDWORKS
PDM database. The file check in operation is two times faster than before.

Availability of SOLIDWORKS PDM Toolbar and CommandManager Tab
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You can access SOLIDWORKS PDM and all its commands from a dedicated SOLIDWORKS
PDM toolbar and the CommandManager tab in SOLIDWORKS when you select the
SOLIDWORKS PDM add-in.

Additional Options in the Task Pane Shortcut Menu and Toolbar

The Task Pane of the SOLIDWORKS PDM add-in has new options in the shortcut menu
and toolbar. Also, some of the existing options are updated. All the options are organized
in meaningful groups for better clarity.

For example, the following are the options added:

• Browse to : Opens the selected file in the same SOLDWORKS PDM File Explorer
window.

• Browse to in a NewWindow : Opens the selected file in a new SOLDWORKS PDM
File Explorer window.

• Data Card and Where Used: Display information of the data card and where it is
used. These options are grouped with the History option.

The Edit option is renamed as Edit Component .

You can customize the Task Pane toolbar to include options you use frequently.
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Support for SSL or TLS Authentication in SMTP Email Notification

You can enable Secured Socket Layer (SSL) or TLS (Transport Layer Security)
authentication in the SMTP email notification.

In the SOLIDWORKS PDM Administration tool, you can select EnableSSL underMessage
System > SMPT > SMTP Setting to enable SSL or TLS authentication in the SMTP
email notifications. It is a two-way authentication along with the login credentials.

The following SMTP servers are supported:

SMTP ServerMail Server

smtp.gmail.comGmail®

smtp.outlook.comOutlook®

smtp.office365.comMicrosoft 365®

smtp.mail.yahoo.comYahoo®
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Display Options - Show Image Preview (2025 SP1)

In the SOLIDWORKS PDM File Explorer, you can view a thumbnail or a full preview in the
Preview tab based on the following file types using Display > Options > Show Image
Preview:

• SOLIDWORKS Files
• eDrawings Files
• DWG/DXF Files
• Neutral Format CAD Files
• Third-party CAD Files
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Card Controls Options (2025 SP1)

In the SOLIDWORKS PDM Administration tool, you can select one of the following as a
Search match type while editing or adding List and Combobox card controls to the
search and file card:

• Exact: You can search for files, folders, and variables in the SOLDWORKS PDM File
Explorer whose search results exactly match the search input.

For example, if you search for weldments in Name, the search results include only
those files, folders, or variables with the exact name weldments. If you want all files
that include weldments in the name, enter an asterisk (*) as a wildcard, for example
weldments* or *weldments*.

• Implicit wildcard: You can search for files, folders, and variables in the SOLDWORKS
PDM File Explorer whose search results include the search input.

For example, if you search for weldments in Name, the search results include all files,
folders, or variables whose names include weldments (for example, weldments,
weldments_box, and weldmentspro).
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Configuring the Convert Task (2025 SP1)

In the SOLIDWORKS Administration tool, while configuring a convert task, you can use
the following advanced conversion options for the .stl and .igs output file formats.

Advanced Conversion OptionsOutput File Format

Bounded Surface (type 143): Select to convert
the faces of the part, assembly, or the selected
surfaces and its boundaries defined by other IGES
entities, for example, curves and edges.

IGES (*.igs)

Custom option under Resolution with the following
sub options:

• Deviation Tolerance: Controls whole-part
tessellation. Lower numbers generate files with
greater whole-part accuracy.

• Angle Tolerance: Controls small-detail
tessellation. Lower numbers generate files with
greater small-detail accuracy, but those files take
longer to generate.

STL (*.stl)
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You can access these options under Tasks > Convert > Open > Conversion Settings
> Conversion Options.

These options are similar to the SOLIDWORKS Export system options for the .stl and
.igs file formats. For more information, see SOLIDWORKS Help: IGES Export Options
and SOLIDWORKS Help: STL, 3D Manufacturing Format, and Additive Manufacturing File
Export Options.

Search Favorites (2025 SP1)
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In the SOLIDWORKS File Explorer, you can use the Run Search Favorite on Load
functionality to view Search Favorite results for files and folders by selecting the Search
Favorite. The functionality is available with the integrated search and the Search Tool.

When this option is not selected, you can view the Search Favorite results by selecting

the Favorite Search and clicking Start Search

Electrical Assembly Bill of Materials (2025 SP1)

In the SOLIDWORKS PDM File Explorer, in the Bill of Materials tab you can view the
Electrical assemblies BOM details.

For Electrical assemblies, you can view:

• The parent-child hierarchical and indented structure in the Computed BOM for CVD
files.

• The Manufacturer Parts Bill of Materials view.
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16
SOLIDWORKS Manage

This chapter includes the following topics:

• Batch Updates for Link to 3rd Party Fields
• Sync with SOLIDWORKS PDM
• Future Date Notifications
• Batch Updates for Process Fields
• Send Affected Items to New Processes
• Collaboration Comments in File Sharing
• Client Version Check
• Flat BOM Groupings
• Adding Automated Task Subject Information
• Project Snapshots
• Tasks from Cancelled Processes
• Application Programming Interface
• Creating New Process Records from Existing Process Records
• Send to Process for Affected Items
• Affected Items in Microsoft File Explorer
• Thumbnails for BOM Copy From
• Installing the SOLIDWORKS Manage Web API

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Batch Updates for Link to 3rd Party Fields

You can update Link to 3rd party field values for some or all records in an object.

Nonadministrators can update the values for selected records in the Main Grid or for all
records on a page. Administrators can update the values for all records in an object. This
restricts users from affecting system performance if there are many fields or ones with
complex queries.

This is a convenient way to populate a new Link to 3rd party field without writing a
separate SQL query.

Implementing Batch Updates to Link to 3rd Party Fields

1. Navigate to an object that has Link to 3rd party fields.
2. Select records, then right-click and click Tools > Reload “Link to 3rd party” fields.
3. In the dialog box:

a) Specify options.
b) Click Start.
c) After the fields update, click Close.
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Sync with SOLIDWORKS PDM

All users can sync selected records in the Main Grid of a SOLIDWORKS PDM object.

SOLIDWORKS Manage reads data from the SOLIDWORKS PDM database, then synchronizes
the information in the SOLIDWORKS Manage database. Previously only administrators
could sync records in the System Administration tool.

Right-click a record and click Tools > Sync with SOLIDWORKS PDM.

Future Date Notifications
You can send a notification after a certain date and time for a process notification.

The setting remains active even after a process finishes unless you restrict the notification
by a condition. This causes a notification such as a renewal or follow-up reminder to be
sent out after a process finishes.

Creating Future Date Notifications

1. In the System Administration tool, right-click a process and click Administration.
2. In the Process Wizard, on the Fields page, specify a Date field to contain the date

used to send the notification.
If the process already has a suitable Date field, you can skip this step.

3. On the Workflow Properties page, select:
a) A stage for when to send the notification.
b) The Visibility node.

4. Specify the Date field you defined in step 2 to specify the notification send date.
For example, specify the Default Value as the current date andWhen? to End. This
specifies the date for when the process stage goes to the next stage.
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5. Select Notifications for the stage and edit an existing notification or create a new
notification.

6. In the Stage Notifications dialog box, on the General tab in:
a) When to send, select Custom.
b) Select Date Field, select the Date field you defined in step 2.
c) (Optional) Time, specify the time of day on the selected date to send the

notification.
d) (Optional) Adjustment days, add days to the Select Date Field.
e) Click Save then Close.

Batch Updates for Process Fields

You can edit fields for multiple process stages with the Batch Edit tool.

With the Batch Edit tool, you can change a field for all stages in one place. Previously,
you had to select each stage in the workflow diagram, then save the edited field.

Implementing Batch Updates to Process Fields

1. In the System Administration tool, right-click a process and click Administration.
2. On the Workflow Properties page:

a) Select a stage.
b) Select the Visibility node.
c) Click Batch Edit.
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3. In the Batch Edit Visibilities dialog box:
a) In the left pane, select a Field.

In the right pane, all the stages defined in the process appear under Stage.

b) Change the settings for each stage, then click Save.
c) Repeat steps 3a and 3b for additional fields.

If you select another Field without clicking Save, the changes to the previously
selected field do not save.

d) Click Close.

Send Affected Items to New Processes

You can send affected items from selected processes to new processes.

You can send either the process itself or only its affected items to a new process. This
makes it easier to resend the same affected items from one process to another. Previously,
you had to add each item individually to a new process.

In the Main Grid of a process object, right-click a process and click Send to Process >
Selected items or Affected items of selected items.
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Collaboration Comments in File Sharing

You can specify an option that allows the participants of file sharing to add comments to
each file. This makes it easier to communicate with external users about the shared files.

To enable collaboration comments in file sharing:

1. In the Main Grid of an object, select a record and create a new share or edit an existing
file share in the right pane.

2. In the Share dialog box:

a. Select Enable Collaboration Options.
b. Click the Enable Collaboration Options link.

3. In the Collaboration Options dialog box:

a. Select Show Comments section.
b. (Optional) Select External users can add comments.
c. (Optional) Select Overwrite internal user name in grids to display a generic

name in Created by on the file share web page.
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Client Version Check

You can specify an option to restrict users from signing in if they use an older client
version than the database version.

To perform client version checks:

1. In the System Administration tool, click Advanced > General > Login.
2. Under Check software version on log in, specify an option.

The default setting is Block users if their software version is older than the
database version.

Flat BOM Groupings
You can show multiple lines for the same part number for flat bill of materials (BOM)
views based on a secondary BOM field value.

For example, consider that a part instance from one subassembly has a reference-specific
value of Spare Part, and the same part exists elsewhere in the assembly without a
value. The flat BOM rolls the quantities of the parts with blank values and the parts with
the Spare Part value on two separate lines. This functionality is also available in the
Plenary Web and you can access it in reports.

Previously, there was no way to separate the same part instances into different groups.
All instances rolled into a single line.

Grouping Instances in Flat BOMs

1. On the BOM property tab toolbar, click Format > Flat View (advanced) > Group
By.
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2. Select a field to use for grouping and click Apply.

The BOM shows a line item for the same part number for each value in the selected
group by field.

Adding Automated Task Subject Information

You can include field values from an associated object in the task subject. This makes
task subjects associated with Project, Process, and Case objects more meaningful to
users.

In earlier releases, you could only add the record part number and the current stage
name.

To add automated task subject information:

1. Edit and process an object.
2. In the System Administration tool, open the Process Wizard.
3. On the Workflow Properties page:

a. In the workflow view, select a stage.
b. Select Tasks.
c. Edit an existing task or create a new task.
d. In the Task Template dialog box:

1. At the right end of Subject, click the right arrow icon and select a field.
2. (Optional) Add static text or additional fields.

e. Click Save then Close.
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Project Snapshots

You can capture project record details at certain points in time to create a history of the
changes made to a project record.

Snapshots are available in a property card tab named Snapshots. The tab's left pane
displays the snapshots that you created in addition to the current record. You can compare
the snapshot information to the current record and to other snapshots. The right pane
displays information for the selected snapshot or for the current record. Information in
the right pane includes:

• Details. Displays the record's field values.
• Planning. Shows the work breakdown structure and Gantt chart.
• Tasks. Lists the tasks as they were when you took the snapshot, including progress,
status, and assignment information.

• Deliverables. Shows the deliverables and their lifecycle statuses.
• Timesheets. Displays the timesheets connected to the project.
• Resources. Lists the resources assigned to the project at the time of the snapshot.

Creating Project Snapshots

1. Edit a project object.
2. In the System Administration tool, open the Process Wizard.
3. On the Property Tabs page:

a) Select Snapshots.
b) Select the users or groups to have access to the Snapshots tab.
c) Click Next and make any other changes to the project object.

4. Select the completed wizard page and click Finish.
5. Open a project record and check it out.
6. On the Snapshots tab, click New.
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7. Enter a name and comment for the snapshot.

The snapshot appears in the list with the Current record.

8. Make changes to the project record.
For example, add a project stage and tasks for the new stage.

9. Click Save.
10. Select the Snapshots tab.
11. Select the snapshot and Current record, then compare the information on the Planning

tab.

Tasks from Cancelled Processes
You can control the status of associated tasks from cancelled processes. This eliminates
leftover tasks that you can see after cancelled processes. You can leave edited, unedited,
or completed tasks as unchanged, delete them, or change them to completed when the
associated process is canceled.

To specify what to do for tasks from cancelled processes:

1. In the System Administration tool, open the Process Wizard.
2. On the Options page, under Task Options, specify options for When a process is

cancelled.

Application Programming Interface
A web-based API is available. You can use the API to get data out of SOLIDWORKS Manage
and update or add records.

You install the API through the SOLIDWORKS Manage Server installer in the SOLIDWORKS
Installation Manager. You can access the documentation on the website included in Internet
Information Services (IIS) with the Browse Website link.

Creating New Process Records from Existing Process Records
You can create new process records from existing process records to capture the field
values and other attributes from the source record.

1. In the Main Grid of a process object, right-click an existing process record and select
New From.

2. Make changes in the properties area and select content to copy underWhat do you
want to copy.

3. Click OK.

Send to Process for Affected Items
You can send affected items from one process to a new process.

The new process can be any process that accepts the selected record types.
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If the selected affected items are in a process that has not completed but the affected
items have a Change Status output, you cannot add the affected items to a new
process that also has a Change Status output.

1. Select an existing process record or open its property card.
2. On the Affected Items tab, right-click an affected item record and select Send to

Process.

You can select multiple affected items.

3. In the Select dialog box, select a process object for the new process record.

The new process record appears with the selected records added as affected items.

Affected Items in Microsoft File Explorer
You can navigate to the Microsoft® File Explorer location for a SOLIDWORKS PDM file that
is an affected item in a process.

1. Select an existing process record or open its property card.
2. On the Affected Items tab, right-click an affected item record and select Show in

Windows Explorer.

File Explorer opens with the affected item selected.

Thumbnails for BOM Copy From
When you copy data into a Bill of Materials (BOM) using Copy From, the Select Record
dialog box includes thumbnail images in the search results area. Thumbnails make it
easier to understand the data that you copy.

Installing the SOLIDWORKS Manage Web API
You can install the Manage Web API in the SOLIDWORKS PDM InstallShield Wizard. During
the installation, you can either use the default port or specify another value for the Http
port.

In addition, in the SOLIDWORKS Installation Manager, you can install the Manage Web
API on the SOLIDWORKS Manage Server page and specify the Http port there as well.
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17
SOLIDWORKS Simulation

This chapter includes the following topics:

• Automatic Detection of Underconstrained Bodies
• Bonding Interactions with Offset
• Contact Penalty Stiffness for Shells
• Contact Penalty Stiffness Control for Nonlinear Studies
• Edge Weld Connector
• Enhanced Pin Connector
• Exclude Bodies from Analysis
• General Spring Connector
• Geometry Correction for Surface-to-Surface Bonding
• Mesh

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, and SOLIDWORKS Ultimate.

Automatic Detection of Underconstrained Bodies
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You can detect rigid body modes at the early stage of a linear static study's solution.

The option Automatically detect underconstrained bodies is available from the
System Options - General dialog box. This option detects bodies that are not sufficiently
constrained during simulation and can exhibit translational or rotational rigid body modes.

When the solver detects rigid body modes, you have the option to continue with the
solution, or stop the solution and review the rigid modes using the Underconstrained
Bodies tool.

The automatic detection of rigid bodies is available for linear static studies.

Bonding Interactions with Offset

The enforcement of node-to-surface bonding interactions between geometries within a
user-defined gap is improved.

This enhancement improves the accuracy for bonding offset defined by a user-defined
Gap range for bonding. You can expect to see improved solution accuracy for all bonding
interactions (solid-solid, shell-shell, and solid-shell) that are based on either a draft-quality
or high-quality mesh. The studies that support this enhancement include Linear Static,
Frequency, Buckling, Linear Dynamics, Fatigue, Design Scenario, and Pressure Vessel.
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Contact Penalty Stiffness for Shells

A new algorithm is introduced to apply penalty stiffness for contact interactions of shells.
This enhancement improves performance and accuracy for a large range of shell thickness
ratios.

Shell thickness ratio = shell thickness / characteristic length of shell

The image shows the performance improvement for contact interactions depending on
several shell thickness ratios.

The force magnitude applied for each test case was adjusted for the different shell
thickness/shell length ratios to maintain a small displacement range and similar
maximum displacements across all test cases.

shell thickness / shell length = 0.05shell thickness / shell length = 0.1
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shell thickness / shell length = 0.001shell thickness / shell length = 0.01

The penalty stiffness applies to shell-to-shell, solid-to-shell, surface-to-surface, and
edge-to-surface contact in linear static studies.

Contact Penalty Stiffness Control for Nonlinear Studies

You can adjust a scale factor for the penalty stiffness applied to surface-to-surface contact
interactions when solving nonlinear studies.

The default value for the contact penalty stiffness factor is 1.0, which yields the most
accurate solution. To obtain an approximate solution and assess design iterations faster,
you can specify a value lower than 1.0.

You can set the study-level scale factor for the penalty stiffness in the Nonlinear- Static
dialog box.
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Edge Weld Connector

Several enhancements for the Edge Weld connector improve its usability.

• The program calculates the Estimated weld throat size when you define edge weld
connectors in the Edge Weld Connector PropertyManager. The formulas for the
calculation of the Estimated weld throat size are given in the table.

Estimated Weld Throat SizeWeld Type

Estimated weld size * square root (2) / 2Fillet

Estimated weld size / 2Groove

• The icons forWeld Orientation in the Edge Weld Connector PropertyManager for the
Groove, Single-sided type of connectors are updated to show an accurate
representation of the edge weld type.

• TheWeld Check Plot annotation also lists the Calculated weld throat size and the
Estimated weld throat size for each edge weld connector.
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Enhanced Pin Connector

The introduction of a distributed coupling algorithm enhances the performance of studies
that use pin connectors.

Results from studies with pin connectors that you apply to cylindrical surfaces with large
number of nodes and use the Distributed connection are more accurate.

The solution time for these studies is improved for the Intel Direct Sparse solver.
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In previous releases, when the number of nodes were very large, only a subset of the
nodes participated in the distributed coupling constraints. In SOLIDWORKS Simulation
2025, the distributed coupling constraints for pin connectors include all the nodes on the
cylindrical surfaces.

The solution time with the FFEPlus iterative solver for similar studies is unchanged in
SOLIDWORKS Simulation 2025. However, the stress results are more accurate because
all nodes are considered in the distributed coupling formulation.

This enhancement is available for Linear Static studies, along with the associated Fatigue,
Design, and Pressure Vessel Design studies.

Exclude Bodies from Analysis

You can exclude multiple bodies from an analysis.

From a Simulation study tree, select a folder under the Parts node and use the shortcut
menu to exclude all bodies in the selected folder from the analysis.
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General Spring Connector

You can specify a general spring connector between flat, nonflat, and concentric cylindrical
surfaces.

The general spring connector uses distributed coupling to establish an enhanced spring
connector formulation that improves the performance and accuracy of the simulation
studies.

To accurately represent the general spring connector, you can define up to six stiffness
parameters using a local coordinate system.

The general spring connector is available with SOLIDWORKS Simulation Professional and
SOLIDWORKS Simulation Premium.

To open the General Spring PropertyManager:

In the Simulation study tree, right-click Connections and click General Spring .
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Geometry Correction for Surface-to-Surface Bonding

Simulation accuracy is improved for studies with bonded curved surfaces
(surface-to-surface bonding formulation) when the mesh sizes of the source and target
surfaces differ.

The algorithm that enforces surface-to-surface bonding integrates geometry correction
factors that improve the representation of curved surfaces of cylindrical, spherical, and
conical geometries. The integration of surface geometry correction reduces the stress
noise at the vicinity of bonded curved surfaces, thus improving the solution accuracy.

The image above shows the stress noise reduction at the boundary where solid-to-solid
bonding with geometry correction is applied between two curved surfaces. The geometry
of the bonded surfaces is shown in the image below.
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The studies that support this enhancement include Linear Static, Frequency, Buckling,
Linear Dynamics, Fatigue, Design Scenario, and Pressure Vessel.

Mesh

The total meshing time by the Blended curvature-based mesher is reduced for assemblies
that have multiple identical parts.

The Blended curvature-based mesher creates the midside nodes of the higher-order
elements once, and reuses the midside node positions across repeated identical parts,
thus saving meshing time. The mesh performance improvement is more prominent for
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assemblies with many repeated parts that have curved surfaces and are meshed with a
high-quality mesh.

The image shows the total mesh time reduction for an assembly with 450 parts.
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18
SOLIDWORKS Visualize

This chapter includes the following topics:

• Fading the Ground Floor
• Added Fast Rendering Mode for Stellar
• Render Engine Selection
• Photorealistic Rendering in SOLIDWORKS with the SOLIDWORKS Visualize API
• Visualize Boost Redesign
• Support for Distributed Rendering in SOLIDWORKS Visualize Connected (2025

SP1)
• Enhancing Images with the Camera Bokeh Effect (2025 SP1)
• Fast Mode Updates for Stellar Render Engine (2025 SP1)
• Import Improvements (2025 SP1)
• Updates for DSPBR Shading Model Appearances (2025 SP1)

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, and SOLIDWORKS Ultimate,
or as a completely separate application.

Fading the Ground Floor
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In SOLIDWORKS Visualize, you can fade the ground floor similar to fading parts. This
makes the ground invisible while still affecting reflections and shading of nearby parts.

Enabled, FadedEnabled, Not Faded

During editing and post-processing, there are occasions where hiding the ground floor
becomes necessary. Doing so may alter the visual representation of parts due to the
absence of interactions between the floor and parts.

You can access the Faded property Palette > Scenes > Advanced > Ground Shadow
Catcher.

This feature is supported exclusively in Accuratemode and is not accessible in Preview
or Fast mode.

Added Fast Rendering Mode for Stellar
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SOLIDWORKS Visualize offers Fast mode rendering with the Stellar render engine,
providing real-time interactive rendering for both the Visualize viewport and offline renders.

It uses the Vulkan ray-tracing API and Deep Learning AI technology to achieve real-time
ray-tracing performance, making it ideal for next generation video cards and high
resolutions.

Render Engine Selection

With the completion of the implementation of the Stellar Physically Correct rendering
engine, SOLIDWORKS Visualize has discontinued support for NVIDIA Iray.

Consequently, the option to choose NVIDIA Iray as the rendering engine has been removed
from the Tools > Options menu, so users can no longer select it.

Photorealistic Rendering in SOLIDWORKSwith the SOLIDWORKSVisualize
API

Using the SOLIDWORKS Visualize API, you can create functionality for photorealistic
renderings of SOLIDWORKS models.

This API, available through the SOLIDWORKS Visualize Add-In, allows you to either render
SOLIDWORKS documents directly or convert them into Visualize project files.

For API assistance, click the Help > API Help.
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Visualize Boost Redesign

Visualize Boost has undergone a significant redesign, introducing enhanced capabilities
tailored for managing SOLIDWORKS Visualize render tasks across multiple machines.

With a simplified and intuitive setup process, configuring render jobs across a network
is more efficient than ever.

The latest iteration of Visualize Boost boasts a user-friendly setup interface, streamlined
machine discovery, and heightened stability.

To install and set up Visualize Boost:

1. Use the SOLIDWORKS Installation Manager to install Boost on one or multiple machines
that are accessible in the network.

2. On each Boost machine, do the following:

a. Start SOLIDWORKS Visualize Boost 2025.
b. Go to File > Settings.
c. For one machine, select Coordinator to make it the coordinator node. Leave the

Coordinator check box clear for all other Boost nodes.
d. For non-coordinator Boost nodes, enter the Coordinator IP Address.
e. Click Apply.

3. ln SOLIDWORKS Visualize, go to Tools > Options > Boost, and enter the
Coordinator IP Address.

4. Click Connect.

Once connected, you can choose the Boost Renderer in the Render Wizard/Quality page
to start a render that is distributed over the network.
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Support for Distributed Rendering in SOLIDWORKS Visualize Connected
(2025 SP1)

SOLIDWORKS Visualize Connected supports distributed rendering through Visualize Boost.

To facilitate this functionality, the SOLIDWORKS Visualize Connected interface includes
Boost controls that are identical to those in the SOLIDWORKS Visualize desktop app.

• Tools > Options > Boost

The Boost tab displays the Coordinator IP Address, Boost Port, and Boost Status
for easy access and management.

• Heads-Up Display (HUD) and Render Wizard > Quality

These areas include Boost Status controls, giving you visibility over Boost's activity
and status during rendering.

Avoid running Visualize Boost on the same machine as SOLIDWORKS Visualize
Connected.

For details on installing and configuring Visualize Boost, see Visualize Boost Redesign
and SOLIDWORKS Visualize Help.

Enhancing Images with the Camera Bokeh Effect (2025 SP1)

The Depth of Field (DOF) Bokeh Effect, seen in photography and 3D rendering, creates
blur in out-of-focus areas, giving highlights a soft and circular or polygonal shape. You
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can think of blurred streetlights in a night scene as an example. In traditional photography,
lens aperture blades shape these highlights.

With SOLIDWORKS Visualize, you can fine-tune this effect by adjusting Blade Count and
Blade Angle, allowing you to customize the shape of Bokeh highlights. To access these
parameters, go to Palette > Camera > General > Depth of Field and select both
Depth of Field and Bokeh Effect.

• Blade Count: Specifies the number of aperture blades that shape the Bokeh. Higher
values result in a smoother, more circular effect.

• Blade Angle: Adjusts the orientation of the Bokeh Effect from 0° to 360°.

Fast Mode Updates for Stellar Render Engine (2025 SP1)

The latest updates to Fast mode for the Stellar render engine enhance performance,
usability, and access to critical settings.

• AI Upscaling.

• Fast mode helps you balance performance and visual quality. Depending on your
hardware, the option does not appear.

• Automatic adjusts the AI Upscaling mode based on your viewport resolution.
This option is helpful if you frequently change the viewport size.

• Speed maximizes responsiveness with lower detail. Quality provides the sharpest
visuals with reduced performance. Moving the slider in between these options offers
a balanced middle ground between interactivity and image clarity.

• Camera Motion Blur.

By adding natural blur to moving objects, Fast mode creates smoother visuals while
maintaining performance.

• Simplified Controls.
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You no longer need to specify pass limits or time in the Render Wizard for final renders.
This removal ensures high-quality results and lets you focus more on creativity.

Import Improvements (2025 SP1)

Import improvements in SOLIDWORKS Visualize improve format loading, and give you
more control over mesh refinement quality.

SOLIDWORKS Visualize uses a new format-loading component, replacing older import
methods. This update improves mesh refinement quality for better detail and accuracy
during import. It also handles materials, textures, and specific file types more efficiently,
speeding up visualization loading. In addition, the mesh refinement experience is designed
to align more closely with SOLIDWORKS, providing a more consistent workflow.

The Geometry tab in the Import Settings dialog box offers the followingMesh Refinement
modes:

• Default

Delivers the fastest import speed while preserving full material properties, including
textures. This mode uses either existing tessellation data or default settings.

• Simple

Supports basic mesh refinement with limited material properties (color only). You can
adjust mesh refinement using a single slider and later retessallate part of the model
using the Models tab in the Palette, which provides the same Mesh Refinement
controls.

• Advanced

Offers more flexibility to customize mesh refinement settings, although material
properties are limited to color only. Similar to Simple mode, this mode lets you
retessallate parts of the model after import using the Models tab in the Palette.
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Updates for DSPBR Shading Model Appearances (2025 SP1)

SOLIDWORKS Visualize enhances appearance workflows for the DSPBR Shading Model
with the Translucency Color and Thin Film parameters.

These parameters offer more control over how light interacts with materials:

• Translucency Color lets you add a diffuse color to transparent materials, similar to
the Subsurface Color. It is helpful for simulating objects like translucent curtains.

• Thin Film effect simulates light diffraction, creating colorful patterns on materials.
This is ideal for effects like soap bubbles or oil on water.

For older DSPBR appearances, click Convert next to the Appearance Type to update
them and access the latest features and controls. A tooltip shows the current version and
the version to which it will be converted. New appearances automatically include these
parameters in the user interface.
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19
SOLIDWORKS CAM

This chapter includes the following topics:

• Contour Mill Toolpaths That Machine from Bottom to Top
• Automatic Feature Recognition of Turn Features
• Dockable Legends for Toolpath Simulations

SOLIDWORKS® CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, and
SOLIDWORKS Ultimate.

Contour Mill Toolpaths That Machine from Bottom to Top
You can specify an option to generate Contour Mill toolpaths that machine from bottom
to top of 2.5 Axis Mill features.

This option helps when machining:

• Tapered features
• Keyway slot features (Recommended tools for such features include the lollipop and
keyway tools.)

To specify this option:

1. In the Operation Parameters dialog box, on the Contour tab, under Depth processing,
select Bottom to top.
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Automatic Feature Recognition of Turn Features

Options are available for recognizing Turn features using Automatic Feature Recognition
(AFR).

In previous releases, when you used AFR with the Extract Machinable Features (EMF)
tool, SOLIDWORKS CAM recognized all Turn features in the model. You could not control
which feature types to recognize.

To specify these options:

1. Click Tools > SOLIDWORKS CAM > Options.
2. In the dialog box, on the Turn Features tab, under Extract Machinable Features,

specify Feature types options.

DescriptionOption

Recognizes profile ODs in the active part through the Extract
Machinable Features tool.

Profile OD

Recognizes profile IDs in the active part through the Extract
Machinable Features tool.

Profile ID
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DescriptionOption

Recognizes face features depending on the stock type:
• Round bar stock. Recognizes a single face feature at the
start of the part model.

• Any stock type other than round bar stock. Recognizes:

• Face features at the start of the part model. (These
features appear under the same Turn Setup as other
recognized Turn features.)

• Face features at the end of the part model. (These
features appear under the reversed Turn Setup.)

When cleared, the software does not create a face feature
under the Turn Setup. You can add face features using
Interactive Feature Recognition.

Face Feature

Recognizes groove features in the active part through the
Extract Machinable Features tool.

Groove Feature

Recognizes the specified type of cut off features:
• Bar Stock. If the stock type is a bar stock, recognizes
Cut Off features under the same Turn Setup as the other
recognized features.

• Other Stock Types. If the stock type is anything except
a round bar, recognizes Cut Off features under the same
Turn Setup as the other recognized features.

Cut Off

Dockable Legends for Toolpath Simulations
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During toolpath simulations, you can move the legend that shows the graphical comparison
of the machined part and the design part.

In the Simulate Toolpath PropertyManager, under Display Options, click Show
Difference . In the graphics area, you can move the legend.
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20
CircuitWorks

This chapter includes the following topics:

• Undo Latest MCAD Changes in CircuitWorks (2025 SP1)
• Restore Collaboration State after SOLIDWORKS Restarts or Crashes(2025 SP1)

CircuitWorks™ is available in SOLIDWORKS® Standard, SOLIDWORKS Professional, SOLIDWORKS
Premium, and SOLIDWORKS Ultimate.

Undo Latest MCAD Changes in CircuitWorks (2025 SP1)

You can now undo the latest MCAD changes if the ECAD has not started working on them.

When MCAD proposes a change, you can reverse it in the EDMD Collaboration section
if ECAD has not processed the task. This restores both SOLIDWORKS and CircuitWorks
to the last synchronized state.

Benefits:

• Undo unnecessary or incorrect MCAD changes to keep CircuitWorks and SOLIDWORKS
in sync.

• Easily revert to a previous state without affecting other ongoing tasks.
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To revert MCAD changes:

1. In CircuitWorks, select the EDMD collaboration section.
2. Click Revert MCAD Changes.

Revert MCAD Changes is available only if MCAD made the last change.

Restore Collaboration State after SOLIDWORKS Restarts or Crashes(2025
SP1)

CircuitWorks now includes a collaboration recovery feature that lets you resume your
ECAD and MCAD collaboration smoothly in the event of a SOLIDWORKS restart or crash.

After a restart or crash, open the first backup file in the EDMD Collaboration folder (identify
the baseline .idx file by its timestamp) to resume collaboration. This preserves your
workflow and minimizes disruption.
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21
SOLIDWORKS Composer

This chapter includes the following topics:

• Composer Plug-In for Adobe Acrobat
• Prevent Outline Generation for Hidden Geometry

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Composer Plug-In for Adobe Acrobat
The Composer plug-in for Adobe® Acrobat® is no longer supported by 64-bit Adobe
configurations.

It is still supported by 32-bit Adobe configurations.

Prevent Outline Generation for Hidden Geometry
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The GenerateOutlineForHiddenActor property available in the Viewport category of
the Advanced Properties page specifies whether or not hidden actors are outlined in render
mode.

To prevent outlines from being generated by hidden actors, clear this option. This saves
time when using render mode for large assemblies.
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22
SOLIDWORKS Electrical

This chapter includes the following topics:

• 3D Tab (2025 SP1)
• Cable Management
• Distribute Terminals
• New Variables in Formula Management
• Update Data and Replace Data in SOLIDWORKS Electrical 3D
• Wire Termination Types

SOLIDWORKS® Electrical is a separately purchased product.

3D Tab (2025 SP1)

The user interface of the 3D tab in the Application Settings dialog box has been updated.

User Interface Update
A dynamic property list replaces static check boxes.
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The title Options for SOLIDWORKS Electrical 3D is added to improve the organization
of the options.

Preserve Association Option
The Preserve associations if assembly is unsaved option lets you preserve associations
between 3D components and electrical parts, even if you do not save the SOLIDWORKS
assembly.

Benefits: This option enhances workflow flexibility and prevents data loss.

To access this option, click Tools > SOLIDWORKS Electrical > Tools > Application
Settings > 3D.

Cable Management

Cable management and configuration is enhanced for a better user experience.

• In the Cable reference properties dialog box, you can specify the Mark root option in
the Properties tab. When you add a cable to a project from the cable reference, it
automatically copies the Mark root from the cable reference to the cable's mark root.
This value is also accessible for filters.

• There are new variables for efficient cable organization:

• Position
• Component Origin/Destination
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Distribute Terminals

The Distribute terminal tool lets you link symbols to specific circuits and pins,
simplifying the depiction of complex terminal arrangements in electrical schematics. It
offers an intuitive interface for dynamic circuit and pin selection, ensures precise
symbol-to-terminal mapping, and improves design accuracy.

You can select a specific terminal when adding a new terminal strip, in addition to selecting
the circuit. It distributes a single circuit over multiple schematic symbols.

This functionality is available for terminal components only.

The Distribute terminal tool also lets you change the mapping between symbol
connection points and component circuit terminals. This command is enabled when two
terminals are selected. You can switch component connections between different circuits.

The Component Properties dialog box contains a Terminal section that has a list of
terminals with columns for Circuit, Index, Mark, and Relation.

Distributing Terminal Components

You can use the Distribute terminal tool to manage and switch component connections.

To distribute a terminal:

1. Click Insert Terminal .

In the Terminal Mark tab, a node for terminals appears in the right pane.

• The software groups terminals of the same circuit together and displays available
circuits for multilevel terminal components.

• Partially used circuits appear as with a half-color/half-grey icon in the Component
tree, showing only free terminals.

158

SOLIDWORKS Electrical



2. Select a component to associate with the circuit terminal.

3. In the Manufacturer part and circuits tab, click Distribute terminal to manage
and switch component connections.

New Variables in Formula Management

New variables are available in the Formula Management dialog box that let you label
origin and destination arrows more effectively. This makes it easier to find and understand
bookmarks, especially when the arrows are in the same book.

In the Formula management: Origin - destination mark dialog box, on the Variables and
simple formulas tab:

• BOOK_TAG_ALWAYS variable appears under BOOK_TAG.
• STRZ(VAL(BOOK_ORDERNO_ALWAYS), 2, 0) appears under

STRZ(VAL(BOOK_ORDERNO), 2, 0).

In the Attribute management dialog box, #BUN_TAG_ALWAYS appears under
#BUN_TAG.
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Update Data and Replace Data in SOLIDWORKS Electrical 3D

Update data and Replace data tools are available in the SOLIDWORKS Electrical 3D
Project toolbar.

You can also access these tools from Tools > SOLIDWORKS Electrical > Process.

In earlier releases, these tools were only available in SOLIDWORKS Electrical Schematic.
With these tools in SOLIDWORKS Electrical 3D, you can update project data such as
manufacturer part properties, cable references, symbols, and title blocks. You need not
switch back to the SOLIDWORKS Electrical Schematic application each time to update or
refresh the changes.

Wire Termination Types
You can add user data and customize details about wire termination types in your electrical
designs.

• User data and Translatable data are added in the Wire termination type properties
dialog box.

• New attributes are available for user data and termination types.
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23
SOLIDWORKS MBD

This chapter includes the following topics:

• Saving DimXpert Dimensions to Library Features (2025 SP1)
• Creating DimXpert Dimensions from Sketch Dimensions
• Using the SOLIDWORKS MBD Add-In with SolidNetWork License
• Delete General Profile Tolerance
• Creating Length Dimensions in Drafted Features
• Creating Two Separate Positional Tolerances for Slots

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, and SOLIDWORKS Ultimate.

Saving DimXpert Dimensions to Library Features (2025 SP1)

You can save DimXpert dimensions to library features.

Benefits: You can save the DimXpert dimensions to library feature parts to reuse them
when you use a library feature on a model.

To save DimXpert dimensions to library features:
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1. Click Add to Library on the Task Pane Design Library tab.
2. In the PropertyManager:

a. For Items to Add, select features from the graphics area or FeatureManager
design tree.

b. For File name, type a file name (the default is document name.)
c. For the Design Library folder, select a subfolder to add the library feature.
d. For Description, type a description to be displayed in the item's tooltip.

e. Select Include MBD Dimensions and click .

Creating DimXpert Dimensions from Sketch Dimensions

You can create DimXpert dimensions from sketch dimensions.

To create DimXpert dimensions from sketch dimensions:

1. Click Insert Dimensions (MBD Dimension toolbar) or Tools >MBD Dimension
> Insert Dimensions.

2. In the PropertyManager:

a. For Features, select features from the graphics area or FeatureManager® design
tree.

b. For Sketch Dimensions, select the dimensions in the graphics area to create
DimXpert dimensions.

c. Click .

162

SOLIDWORKS MBD



Using the SOLIDWORKS MBD Add-In with SolidNetWork License

SolidNetWork License (SNL) customers can use the SOLIDWORKS MBD add-in.

To use the SOLIDWORKS MBD add-in with SNL:

1. In SOLIDWORKS, click Tools > Add-Ins.
2. In the dialog box, under SOLIDWORKS Add-ins, select SOLIDWORKS MBD and

click OK.

Delete General Profile Tolerance
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In Design with SOLIDWORKS, you can delete a general profile tolerance.

To delete a general profile tolerance, in the DimXpertManager , right-click a general
profile tolerance and click Delete.

Creating Length Dimensions in Drafted Features

You can create length dimensions in drafted features.

You can use the DimXpert Size Dimension tool to create dimensions for drafted
features, such as wedges and cones. The dimension is typically a distance dimension with
tolerances. The dimension can be between two edges of draft ends or circular edges of
a cylinder.

164

SOLIDWORKS MBD



Creating Length Dimensions in Wedges

To create length dimensions in wedges:

1. Click Size Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Size Dimension.

2. Click the face of one of the side planes.

3. In the feature selector, click Create Width/Wedge Feature .
4. Click the face of the second side.
5. Click the face of the end plane, which is the plane that intersects the two sides, and

click .
6. Place the angle dimension.

7. Click Size Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Size Dimension.

8. Click the end plane.
9. Click in the graphics area to place the width dimension.
10. Apply a geometric tolerance to the width dimension to create the position callout.
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Creating Length Dimensions in Cones

To create length dimensions in cones:

1. Click Size Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Size Dimension.

2. Click the conical face to create the cone feature.
3. Place the angle dimension.
4. Click the top edge to create the intersect circle feature and diameter dimension.

See SOLIDWORKS Help: DimXpert Features.

5. Apply a geometric tolerance to the intersect circle feature to create the position callout.
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Creating Two Separate Positional Tolerances for Slots

You can create two separate positional tolerances for slots.

To create two separate positional tolerances for slots:

1. Click Size Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Size Dimension.

2. Click the edge of the length of a slot and click in the graphics area to place the
dimension.

3. Click .
4. Apply a geometric tolerance and a position tolerance and click in the graphics area

to place the tolerance.

5. Click .

6. Click Size Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Size Dimension.

7. Click the edge of the width of a slot and click in the graphics area to place the
dimension.

8. Click .
9. To choose the type of dimension to apply to a feature, such as the "6XR" in the

illustration, see SOLIDWORKS Help: Using the Dimension PropertyManager.
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24
DraftSight

This chapter includes the following topics:

• Bookmarks for Batch Save to 3DEXPERIENCE (DraftSight Connected Only)
• Open Dialog Box (DraftSight Connected Only)
• Managed DS License Server
• DGN File Export
• Auto-Fill Table Cells
• Accessing Tables and Creating Table Breaks
• Libraries of Dynamic Blocks
• Dynamic Search in an Options Dialog Box
• Dimension Styles Dialog Box
• Block Structure Palette
• Editing Clipped External References and Blocks
• Drawing Order
• Managing Spacing Between Dimensions
• Menu Bar Visibility
• Dimensional Constraints for Custom Blocks
• FLATTEN Command
• Visual Styles
• Export Models to Unreal Engine
• Printing in MacOS
• AMUSERHATCH Command (DraftSight Mechanical Only)
• Table Edits
• Import STEP Files
• DWGUNITS Command
• PDF Export and Batch Print Usability
• Blocks in the Design Resource Palette
• Multiple Visibility Elements
• Lasso Selection

DraftSight® is a separately purchased product that you can use to create professional CAD
drawings. It is available as DraftSight Professional, DraftSight Premium, and DraftSight
Mechanical. In addition, DraftSight Enterprise and Enterprise Plus are available on network
license. 3DEXPERIENCE® DraftSight is a combined solution of DraftSight with the power of the
3DEXPERIENCE platform.
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Bookmarks for Batch Save to 3DEXPERIENCE (DraftSight Connected Only)

You can batch upload files to bookmarks on the 3DEXPERIENCE platform.

To open the Batch Save to 3DEXPERIENCE - Options dialog box, on the ribbon, click
DraftSight > Batch Save to 3DEXPERIENCE.

Select a Bookmark Dialog Box

You can use this dialog box to select an existing bookmark or create new bookmarks.

To access the Select a Bookmark dialog box, in the Batch Save to 3DEXPERIENCE - Options

dialog box, click .

Toolbar

DescriptionTool

Creates a new bookmark.New Bookmark

Marks bookmarks as favorites.Favorite

Expands the folder structure.Expand All

Searches for the file in the selected bookmark.Find in Tree

Sorts the bookmarks in alphabetical order.Alphabetical Order

Sorts the bookmarks based on the creation date.Date Order
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Favorites
Lists the favorite bookmarks.

Bookmarks
Lists the bookmarks available on the 3DEXPERIENCE platform and newly created
bookmarks.

Open Dialog Box (DraftSight Connected Only)

You can use the Open dialog box to open recently opened drawing files and files on
3DSearch, locked by you, in My Content, and in bookmarks.

The dialog box contains various options that let you display files in the Results panel.

To open the dialog box, do one of the following:

• Click Open (Quick Access toolbar).
• Click File > Open.
• Type Open in the command window.

DescriptionOption

Displays the recently opened files. The cloud
symbol denotes the file that you have
opened on the 3DEXPERIENCE platform.
Select the file and click Open to open it.

Recent

Displays the files saved on the
3DEXPERIENCE platform.

3DSearch

170

DraftSight



DescriptionOption

Displays the files locked by you. Click Clear
Filter to clear the results and display all
files.

Locked by Me

Displays the files created by you. Click
Clear Filter to clear the results and display
the files created by all users.

My Content

Displays the bookmarks and files saved to
the bookmarks.

Bookmarks

Opens the locally saved files.This PC

Opens the file that you selected from
results.

If you are working in the offline mode,
you can open only recently opened and
locally saved files.

Open

Managed DS License Server

DraftSight supports Managed DS License Server.

Managed DS License Server (DSLS) is also known as the Managed Licensing Service. With
Managed DSLS, on-premises customers do not require a physical computer to install the
DSLS.
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See Managed Licensing Service.

Setting up Managed DSLS in the Deployment Wizard

You can use theManaged DSLS server type when you set up the server in the DraftSight
deployment wizard.

To set up Managed DSLS in the deployment wizard:

1. In DraftSight Deployment Wizard, select Dassault Systemes License Server
(DSLS).

2. For Server Type, select Managed DSLS.
3. Enter the server details that you received when you selected managed licensing

service mode.

Setting up Managed DSLS in DraftSight

You can set up the Managed DSLS server type when you install DraftSight.

When you install DraftSight, select Dassault Systemes License Server (DSLS) as the
license type.

To set up a Managed DSLS in DraftSight:

1. In the DraftSight License Administrator, select Add Server.
2. For Server Type, select Managed DSLS.

DGN File Export
You can use the EXPORTDGN or DGNEXPORT commands to export DGN files.

To use DGN file export:

Do one of the following:

• On the ribbon, click Menu > Export > DGN Export.
• On the menu, click Menu > Export > DGN Export.
• Enter EXPORTDGN or DGNEXPORT in the command window.
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Auto-Fill Table Cells

You can use the TABLE command to automatically enter data in the adjacent cells of a
table.

This feature is useful where data follows a logical or repetitive order, such as filling in
dates, sequential numbers, days of the week, months, etc. Auto-fill is an efficient tool to
handle large data sets and ensure consistency.

To access the TABLE command:

Do one of the following:

• On the ribbon, click Annotate > Table > Insert.
• On the menu, click Draw > Table.
• Enter TABLE in the command window.
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Accessing Tables and Creating Table Breaks

You can use the TABLE command to create tables and break large tables into multiple
tables so they fit in a drawing area or sheet.

For tables with many rows, you can break the table so the table displays the rows side
by side.

You can define the table height by dragging the grip point or you can enter the height in
a drawing unit in the Properties palette.

To access tables:

Do one of the following:

• On the ribbon, click Annotate > Table > Insert.
• On the menu, click Draw > Table.
• Enter TABLE in the command window.
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Libraries of Dynamic Blocks

The tool palettes include more than 400 dynamic blocks. The blocks are parametric and
compatible with AutoCAD®.

Instead of creating new blocks to adapt or update a design, you can adjust the size,
shape, and configuration of the dynamic blocks. This can simplify the drawing process
and reduce repetitive tasks.

The dynamic blocks include symbols for architecture, interior design, HVAC, electricity,
plumbing, civil engineering, and urban planning. They are grouped into palettes according
to the industry focus.
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Dynamic Search in an Options Dialog Box

The search functionality in the Options dialog box is more intuitive and user friendly,
ensuring that you find options quickly.

In the Search box of the Options dialog box, start to enter a term or system variable
name to see a list of options containing the string that you entered. Relevant options
appear in a list. You can click an option to go directly to the specified option.

To use the dynamic search in the Options dialog box:

Do one of the following:

• On the ribbon, click Manage > Customization > Options.
• On the menu, click Tools > Options.
• Enter OPTIONS in the command window.
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Dimension Styles Dialog Box

The Dimension Styles dialog box is simplified for editing Dimension Styles.

When you edit Dimension Styles, the user interface more closely resembles the AutoCAD
interface. This ensures a smoother transition for users migrating from AutoCAD to
DraftSight.

To access the Dimension Styles dialog box:

Do one of the following:

• On the ribbon, click Annotate > Dimension > Dimension Style.
• On the menu, click Format > Dimension Style.
• Enter DIMSTYLE / DIMENSIONSTYLE in the command window.
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Block Structure Palette

The Block Structure palette helps you visualize, manage, and navigate complex block
hierarchies. It enhances the efficiency and organization of design and drafting tasks.

A block structure is an arrangement of nested blocks that create a hierarchy. The Block
Structure palette displays the nested block structures and provides a way for you to
manage the blocks.

The palette provides the following benefits:

• Hierarchy visualization. This helps when dealing with large and intricate designs that
have numerous nested blocks.

• Get a structured view of block organization within a drawing.
• Display a visual representation of the block structure for a selected block instance.
• Facilitate the creation and management of hierarchical block structures.
• Highlight nested blocks within the main block or parent block. A block may serve
as a nested block within several parent blocks. The palette displays the block as a
nested element within all relevant parent block structures.

• Support for nested-inside-nested block structures.
• Collapse or expand the block structure.
• Control the level of detail displayed.
• Show or hide individual block instances in the graphics area.
• Manage the visibility of specific blocks within the structure.

• Block management. Enhanced organization ensures that the CAD drawing remains
coherent and easier to work with.

• Access and edit nested blocks directly from the palette, streamlining the editing
process when blocks contain other nested blocks. For example, a window block
nested within a wall block.
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• Copy blocks from one area of the drawing and paste them elsewhere, maintaining
the hierarchical structure. This simplifies the process of reusing design elements
and maintaining consistency in the drawing.

• Rename, group, organize, or delete blocks within the palette.
• Nest a block within another block in the drawing.

• Navigation. This makes it easier to locate and edit specific elements within the design,
saving time and effort.

• Navigate through the drawing by selecting blocks in the palette.
• Locate and focus on particular elements within complex block structures.
• Zoom in on individual block instances in the graphics area.

To open the Block Structure palette:

• On the ribbon, click Insert Tab > Palettes Section > Block Structure.
• On the menu, click Tools > Sheet Set Manager > Block Structure.
• Enter BLOCKSTRUCTURE in the command window.

Editing Clipped External References and Blocks

When you clip a block or an externally referenced (xref) drawing, you can resize or edit
their boundaries with grips. In earlier releases, you had to recreate the clip each time
you resized or edited the boundaries.

This makes it easier to isolate a specific entity or area from the block or xref drawing to
display in the graphics area.

To edit clipped external references and blocks:

Do one of the following:

• On the ribbon, click Insert > Reference > Clip > Reference.
• On the menu, click Modify > Clip > Reference.

179

DraftSight



• Enter CLIPREFERENCE (XCLIP) in the command window.

Drawing Order

The Drawing Order command has options tailored to specific entity types. The options
offer more control over the visibility of annotations, further streamlining the design
process.

The options provide:

• Improved clarity. Ensures that crucial design elements, such as dimensions and
annotations, are visible in the visual hierarchy.

• Efficient workflow. Allows granular control over layering to efficiently manage the
visibility of different elements, reducing the time spent on manual adjustments.

• Enhanced precision. Provides more precision in CAD designs by bringing specific
elements to the front and sending others to the back.
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DescriptionOption

Brings all annotation entities, including text,
dimensions, and leaders, to the forefront of
the design.
By consolidating annotations in the
foreground, you enhance the communication
of critical information, improve the legibility
of design annotations, facilitate better
comprehension of measurements, and
simplify the review and presentation
process.

You can create more precise, visually
appealing, and impactful drawings while
promoting efficient collaboration and
communication.

Bring Annotations to Front

Relegates hatches to the background,
ensuring unobstructed visibility of
underlying entities.
This is useful when hatch patterns interfere
with the clarity and comprehensibility of the
design, providing clearer drawing views.

Send Hatches to Back

Relegates references to the background,
optimizing the visibility of primary design
elements.
This lets you focus on the key components,
resulting in improved efficiency and
accuracy during the design process.

Send References to Back

Consider a user has a detailed floor plan for a commercial building. The project involves
several dimensions, annotations, and graphical elements, making layers and visibility
crucial for clarity and precision.

By using the Bring to Front and Send to Back options, you have more control over layering.
You can bring dimensions, leaders, text, and annotations to the front, while sending
hatches, drawings, and images in DGN and PDF formats to the back.

To access the TEXTTOFRONT, HATCHTOBACK, or REFERENCETOBACK commands:

Do the following:

MenuRibbon

Tools > Display Order > Bring
Annotations to Front > Text Only

View > Order > Bring Text to Front

Tools > Display Order > Bring
Annotations to Front>Dimensions Only

View > Order > Bring Dimensions to
Front
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MenuRibbon

Tools > Display Order > Bring
Annotations to Front > Leaders Only

View > Order > Bring Leaders to Front

Tools > Display Order > Bring
Annotations to Front > All Annotation
Entities

View > Order > Bring All Annotations
to Front

Tools > Display Order > Send Hatches
to Back

View > Order > Send Hatches to Back

Tools > Display Order > Send
References to Back > Drawings Only

View > Order > Send Drawings to Back

Tools > Display Order > Send
References to Back > Images Only

View > Order > Send Images to Back

Tools > Display Order > Send
References to Back > PDFs Only

View > Order > Send PDFs to Back

Tools > Display Order > Send
References to Back > DGNs Only

View > Order > Send DGNs to Back

Tools > Display Order > Send
References to Back > All Referenced
Entities

View > Order > Send All References to
Back

Or

Enter TEXTTOFRONT, HATCHTOBACK, or REFERENCETOBACK in the command window.
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Managing Spacing Between Dimensions

You can use the DIMSPACE command to manage the spacing between dimensions in DWG
files. This ensures precision, clarity, and design consistency in drawings.

With the DIMSPACE command, you have greater precision and can spend less time on
manual adjustments. The DIMSPACE command is similar to AutoCAD functionality for
drawing dimensions, so it is easy to learn if you are familiar with AutoCAD.

To manage spacing between dimensions:

Do one of the following:

• On the ribbon, click Annotate > Dimensions > Adjust Space.
• On the menu, click Dimension > Adjust Space.
• Enter DIMSPACE in the command window.
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Menu Bar Visibility

You can use the ribbon and menu bar simultaneously in the user interface.

The Customize Quick Access Toolbar functionality switches the menu bar visibility.

To specify the MENUBAR visibility, do one of the following:

• On the ribbon, click Customize Quick Access Toolbar > Show Menu Bar / Hide
Menu Bar.

• On the menu, click Customize Quick Access Toolbar > Show Menu Bar / Hide
Menu Bar.

• In the command window, enter MENUBAR.

The System variable 0 is Off and 1 is On.
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Dimensional Constraints for Custom Blocks

When you edit the CustomBlocks, you can use Dimensional Constraints. This lets you
control the distance, length, angle, and radius of entities. Dimensional Constraints can
also constrain the distances and angles between geometric entities or points on entities.

For example, if you design a layout for a circuit board, you must position electronic
components at specific locations. It is important to maintain precise distances and
proportions between components, while allowing for flexibility in their individual sizes.
You can replicate it in different parts of the drawing using it inside a CustomBlock.

You can edit dynamic blocks created in AutoCAD that use Dimensional Constraints. This
transforms the Block into a CustomBlock in DraftSight. The conversion process recognizes
Dimensional Constraints for precise editing within CustomBlocks.

To use Dimensional Constraints for CustomBlocks:

Do the following:

• On the ribbon, click Insert > Block > Edit Block.
• On the menu, click Modify > Entity > Edit Block.
• Enter EDITBLOCK in the command window.

FLATTEN Command
With the FLATTEN command, you can automatically specify the elevation (Z value) of
certain commands as 0.

With certain commands (such as TRIM, FILLET, and JOIN) and other tools (snap, measure,
and dimension), you need to specify the elevation (Z value) as 0. Otherwise, the commands
and tools do not work as expected. The FLATTEN command ensures that the elevation is
0.
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To access the FLATTEN command:

Do the following:

• On the ribbon, click XtraTools > Modify > Flatten.
• On the menu, click XtraTools > Modify > Flatten.
• Enter FLATTEN in the command window.

Visual Styles

You can represent 3D models with an specified appearances. For example, if the model
is in the schematic design stage, you can show the model to a design team in a “sketch
appearance” and present it to customers in a “realistic appearance.”

The different appearances, called Visual Styles, depend on the settings that change the
edge, color, and shading display.

The following table lists the benefits of Visual Styles:

Ensure visual consistency between applications. If
you create visual styles in AutoCAD such as
transparency or wood textures, you can apply the
same styles to models in DraftSight.

Compatibility with AutoCAD

Use diverse rendering options to choose the most
suitable style for projects. This enhances the visual
representation of designs, which improves
communication and understanding.

Enhanced visualization

Create more realistic and visually compelling
drawings. This helps when you share designs with
clients, stakeholders, or team members who may
not be familiar with technical drawings.

Improved communication
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Analyze designs more efficiently. For instance, use
a hidden-line Visual Style to identify obscured or
overlapping elements in complex drawings.

Efficient analysis

Improve the quality of presentations and design
proposals. You can showcase designs as polished
and professional, enhancing the overall impact.

High-quality presentations

Customize Visual Styles to meet specific needs.
You can tailor the visual representation of designs
to match project requirements or personal
preferences.

Customization options

View and manipulate 3D models from different
perspectives. This helps you to understand the
spatial relationships within the design.

3D modeling capabilities

To access the VISUALSTYLES command:

Do the following:

• On the ribbon, click View > Visual Styles panel Visual Styles > Visual Styles
Manager.

• On the menu, click View > Visual Styles.
• Enter VISUALSTYLES in the command window.

Preset Visual Styles

DraftSight provides preset Visual Styles that you can edit to create customized Visual
Styles.

You can adjust lighting for realism, refine edge visibility, or choose a specific face style
to shape the design environment according to project requirements.

DescriptionVisual Style

Uses only lines and curves without shading or
rendering.

2D Wireframe

Suitable for viewing and editing 3D models with
lines and curves.

Wireframe

Uses hidden lines removed to provide a clear view
of visible lines.

Hidden

Adds realistic lighting and shading to the model,
providing a lifelike representation of materials and
textures.

Realistic

Applies a stylized rendering to the model,
emphasizing contours and shapes. Useful for
conceptual design and artistic presentations.

Conceptual
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DescriptionVisual Style

Displays the model with flat shading.Shaded

Combines shaded surfaces with visible edges to
define the boundaries of objects in the model.

Shaded with Edges

Displays the drawing in varying shades of gray to
differentiate between different objects and their
elevations. This provides a monochromatic, effective
representation.

Shades of Gray

Makes all objects transparent so you can see
through the model. Helpful for analyzing complex
assemblies.

X-Ray

Applies a hand-drawn, sketch-like appearance to
the model, giving it a more artistic and informal
look.

Sketchy

Export Models to Unreal Engine
You can export DWG file content to the Unreal Engine environment, which allows you
real-time rendering and visualization.

When you export a CAD model, the export preserves materials, lighting, and other scene
elements. In Unreal Engine, you can create a visualization of the model. This includes
realistic lighting, shadows, and materials that provide a more immersive experience
compared with traditional static renders.

Unreal Engine offers real-time rendering capabilities for you to validate designs more
effectively. By exploring a 3D model during client presentations or collaborative sessions,
you gain clearer communication and understanding. Collaboration is more intuitive for
you and your clients to interact with the design simultaneously.

To export models to Unreal Engine:

Do one of the following:

• On the ribbon, click Application > Export > Export Datasmith.
• On the menu, click File > Export > Export Datasmith.
• Enter EXPORTDATASMITH or EXPORT in the command window.
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Printing in MacOS

If you run DraftSight on macOS®, the Print dialog box uses a similar interface to that in
Windows®. The dialog box is more versatile and user friendly.

Unlike the system Print dialog box, this dialog box provides a broader range of options,
giving you greater control over printing preferences. Printing is simpler and more efficient,
ensuring that drawings print the way you want them.

Users can also switch between Windows and Mac without changing their habits, as the
Windows and Mac versions share the same ribbon user interface.
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AMUSERHATCH Command (DraftSight Mechanical Only)
You can use the AMUSERHATCH command to insert user-defined, predefined, and
nonassociative hatches into object areas. You can modify the properties of a selected
hatch before inserting it into an object area.

Table Edits

You can use advanced features when editing tables.

To make tables more useful, you can:

• Insert and manage blocks in table cells
• Match cell properties
• Repeat features

Improved table functionality:

• Formula options such as AutoSum
• Add rows and columns
• Grips
• Cell shortcut menu and Table contextual ribbon
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Import STEP Files

You can use the IMPORTSTEP command to import 3D models from STEP files.

You can incorporate STEP file models into drawings.

DWGUNITS Command
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The DWGUNITS command converts drawings to other unit systems.

For imperial and metric units, the DWGUNITS command lets you maintain precision and
consistency in various projects. This command enhances the workflow efficiency and
ensures that the drawing adheres to project requirements and industry standards.

PDF Export and Batch Print Usability

You can retain the settings for exporting to PDF and batch printing for the next session.

You can export the PDF and print batch files with the same settings. For printing batch
files, you can retain the same name for PDFs and the same location of the source .dwg
files, then open the PDF files after printing them.
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Blocks in the Design Resource Palette

The Design Resource Palette has improved usability for blocks.

The block names of design resources are fully visible. The block thumbnails are larger so
you can identify the blocks quickly.

Multiple Visibility Elements
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You can use CustomBlocks to attach multiple visibility elements to a single block.

You can efficiently control the visibility of individual entities and without creating multiple
visibility states. Previously, you could attach only one visibility element per block.

Lasso Selection

You can use lasso selection to enhance efficiency and save time.

With lasso selection, you can move the pointer around an area to specify and select
entities in an irregularly shaped contour. This method helps you select complex groups
of entities that do not have standard rectangular boundaries. It simplifies the workflow
and improves productivity.
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25
eDrawings

This chapter includes the following topics:

• Viewing Component References
• eDrawings ActiveX HTML File Format
• Assembly Envelopes
• Supported File Types

eDrawings® Professional is available in SOLIDWORKS® Professional, SOLIDWORKS Premium,
and SOLIDWORKS Ultimate.

Viewing Component References

If a SOLIDWORKS or eDrawings assembly file has components with component references,
you can specify an option in eDrawings to show the component references in the
Components pane.

To view component references:

1. In eDrawings, open a SOLIDWORKS or eDrawings assembly file that has component
references.
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2. In the Components pane, click Options .
3. In the dialog box, select Show component reference.

The component references appear in the Components pane.

eDrawings ActiveX HTML File Format

You can no longer save files as eDrawings ActiveX HTML files .htm files.

If you click File > Send, the Send As dialog box does not appear. Instead, eDrawings
generates an email with the file attached as an .eprt, .easm, or .edrw file for streamlined
functionality.
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Assembly Envelopes

If you open an assembly or assembly drawing that has envelopes, eDrawings displays
the envelope contents with the same appearance as in SOLIDWORKS.

The Components pane displays icons that indicate envelope components.

Supported File Types
eDrawings has updated the supported versions for several file types.

VersionFormat

Up to 2023ACIS® (.sat, .sab)

Up to 2025Autodesk® Inventor® (.ipt, .iam)

Up to V5-6R2024CATIA® V5 (.CATPart, .CATProduct)

Up to V5-6R2024CATIA V6 / 3DEXPERIENCE®

Pro/Engineer 19.0 to Creo 10.0Creo® - Pro/Engineer® (.ASM, .NEU, .PRT,
.XAS, .XPR)

Up to v10.9JT (.jt)

UG11 to UG18, UG NX, NX5 to NX12,
NX1847 to NX2312

NX™ (Unigraphics®) (.prt)
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VersionFormat

Up to 36.1Parasolid™ (.x_b, .x_t, .xmt, .xmt_txt)

1 to 20, ST1 - ST10, 2019 to 2024Solid Edge® (.asm, .par, .pwd, .psm)
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26
SOLIDWORKS Plastics

This chapter includes the following topics:

• Fill Analysis
• Improved Sink Marks Prediction
• Isolate the Cause of Warpage
• Materials Database
• Renamed Warp Analysis Results

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, and SOLIDWORKS Ultimate.

Fill Analysis

There are several enhancements for the Fill analysis.

• The Fill analysis is 25% faster when using fiber-filled materials for plastic parts.
• The Fill analysis predicts weld lines and air traps even in instances of short shots. For
example, the image above shows a short shot (left) and the predicted air traps (right)
for a fill analysis of a part.
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• Rendering of fill-time animations in isosurface mode has been significantly accelerated
(up to 75%) for large models with a high number of elements. The memory required
to generate the fill-time animations has also increased, as SOLIDWORKS Plastics uses
all available memory resources for animation generation.

• The isosurface animation of fill-time plots saved in AVI format has a smoother
appearance with significantly reduced lag because the delay time between successive
result frames decreased.

Improved Sink Marks Prediction

A new solver predicts with improved accuracy the location and depth of sink marks.

The new sink mark solver analyzes geometric features that are likely to induce sink marks,
for example, ribs, bosses, gussets, and internal fillets. The solver then uses this geometric
information to perform a localized analysis to predict the sink marks' depths. For example,
the image above shows improved sink mark predictions at the surface of a game controller
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part that has internal boss and rib features.

The sink mark results are updated as follows:

• The Sink Marks plot from the Fill results is renamed to Sink Marks Estimate at End
of Fill.

• A new plot, Sink Marks at Ejection, is available with the Pack results.
• The Sink-Mark Profile plot from the Warp results is removed, as the prediction of
sink marks based on the conditions at the end of filling is not accurate. Instead, you
can refer to the Sink Marks at Ejection plot to review the location and depth of sink
marks.

The new sink mark solver is available only for solid-hybrid and solid-hexahedral mesh
procedures. The shell mesh procedure continues to use the current sink mark solver.
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Isolate the Cause of Warpage

New result plots for Warp analysis help you isolate the cause of warpage when designing
plastic parts.

Warpage occurs to plastic molded parts because of three main causes: nonuniform
shrinkage, differential cooling, and molecular or fiber orientation. The image shows result
plots of the total deformation and the component deformation because of warpage.
Understanding the dominant cause of warpage helps you make appropriate changes to
the part or mold design, material, and manufacturing process to minimize design defects.

The Warp analysis in SOLIDWORKS Plastics 2025 isolates the cause of warpage by
calculating, at each node, the component of total deformation attributed to each source.
The following result plots are available, along with the Total Deformation plot, to assist
you in identifying the cause of warpage.

DescriptionResult Plot - Warp
Analysis

Shows the deformation that can be attributed to nonuniform
mold temperatures, differential cooling rates between thin and

Deformation –
NonuniformShrinkage

thick sections of a part, and shrinkage variations between the
direction of melt flow and transverse to the direction of melt
flow.
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DescriptionResult Plot - Warp
Analysis

(In general, these deformations occur because of nonuniform
pressure, temperature, and shear stress distributions across
the surface area or throughout the volume of a molded part.)

Shows the deformation that can be attributed to nonuniform
cooling arising from temperature variations across the injection
mold’s core and cavity surfaces.
Nonuniform part cooling generally leads to nonuniform
shrinkage and in-mold stresses, which both contribute to
warpage.

Deformation –
Differential Cooling

Shows the deformation that can be attributed to anisotropy
from the orientation of fillers in the material, such as short
glass fibers or carbon fibers.
For materials without any fillers, this deformation is negligible.

Deformation –
Orientation Effects

You might notice slightly longer Warp analysis solve times because of the additional
computation time required to calculate the components of the total warp deformations.
The result plots that isolate the cause of warpage are available only for the Solid Mesh
procedure.

Materials Database
The plastics materials database is updated according to the latest data from the material
manufacturers.

365 new material grades are added, 142 grades are updated, and 370 obsolete grades
are removed from the database.

Number of New Material GradesManufacturer

123DOMO®

97Envalior™

77SABIC Specialties®

42Covestro®

12MOCOM®

8EMS-GRIVORY®

2CHIMEI®

2Lehmann&Voss&Co.
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Number of New Material GradesManufacturer

1Trinseo®

1Solvay Specialty Polymers®

Number of Updated Material GradesManufacturer

37Covestro®

19LyondellBasell™

18EMS-GRIVORY®

14ARLANXEO®

13BASELL

10CWH, Chemwerk Huls

9MOCOM®

7SABIC Specialties®

6Victrex®

3Mueller Kunststoffe

1Autotech-Sirmax

1Teknor Apex®

1TOTAL®

1Asahi Kasei®

1MILES

1ENICHEM

Number of Removed Material GradesManufacturer

151DSM Engineering Plastics

94Rhodia Engineering Plastics

68LNP Engineering Plastics®

26Covestro®

204

SOLIDWORKS Plastics



Number of Removed Material GradesManufacturer

14Rhone-Poulenc

7SABIC Specialties®

5Monsanto Japan

2Lehmann and Voss

1Trinseo®

1Mitsubishi Chemical Japan®

1Mitsubishi Rayon

Renamed Warp Analysis Results

The Warp analysis results are renamed to ensure consistent terminology.

The image shows the previous and current titles of the Warp analysis results.
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27
Routing

This chapter includes the following topics:

• Create a Flattened Drawing with Cleaner Output
• Customizing Slack Percentages in the Route Properties and Route Segment

PropertyManagers
• Enhancing Pipe and Tube Modifications
• Generate Guidelines to Follow a Route Path
• Improving Performance in Flattened Harness Assembly Edits (2025 SP1)

Routing is available in SOLIDWORKS® Premium and SOLIDWORKS Ultimate.

Create a Flattened Drawing with Cleaner Output
The following updates in flattened drawings provide cleaner output and improved workflow:

• Show/Hide Flatten Route Items: An option to show/hide Leader lines in connector
tables.

• Quantity Display in Balloons: Display quantity in connector balloons, similar to wire
balloons.

• Column and Row Formatting: Prompt users to apply formatting changes for columns
and rows in other tables.

• Table Updates: Prompt users to apply updates to all tables in the drawing.
• Formboard Frame Visibility: In the Flattened Items PropertyManager, an option to

show/hide the formboard frame.
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Customizing Slack Percentages in the Route Properties and Route Segment
PropertyManagers

In the Route Properties and the Route Segment Properties PropertyManagers, you can
define a custom value for the Slack Percentage for individual route segments. This
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value overrides the slack percentage specified in Tools > Options > System Options
> Routing.

Enhancing Pipe and Tube Modifications
When you edit a route assembly containing pipes and tubes, the SOLIDWORKS Routing
software modifies existing components instead of creating new virtual components.

Generate Guidelines to Follow a Route Path

In the Auto Route PropertyManager, you can generate guidelines to follow a route path.
The guidelines identify the nearest sketch segment that leads to its corresponding end
connector and follow that path.

The guidelines help simplify the process of manual harnessing.

To generate guidelines that follow a route path:

1. In the Auto Route PropertyManager, under Routing Mode, select Guidelines.
2. In Routing Path, click Follow Routing Path.
3. To identify sketches in the graphics area:

• Select each sketch individually.
• Box select to choose multiple sketches.
• Select sketch features in the flyout FeatureManager design tree.

4. Click Apply to preview the route path. The sketches representing the route path are
named Routing_path followed by an order number, such as Routing_path 1.

5. Click Done.
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Improving Performance in Flattened Harness Assembly Edits (2025 SP1)
The editing tools in the Edit Flattened Route PropertyManager perform faster, enhancing
your experience for editing flattened harness configurations.

You can make multiple edits and preview them as temporary changes before finalizing,
givingyou more control over the design process.

While you edit, SOLIDWORKS Routing temporarily pauses updates to flattened features.
Updates only occur when you confirm or cancel, ensuring efficient resource use and a
smoother workflow.

For example, after you finish editing, SOLIDWORKS Routing prompts you to confirm.
Clicking OK in the PropertyManager applies the updates to the flattened features, saving
resources by preventing repeated updates with each change. Clicking Cancel removes
the temporary changes.

Previously, each edit triggered a full update, slowing down your workflow. With this
enhancement, only temporary graphics display with each change, without updating the
underlying flattened features.

This functionality does not apply to annotation flatten route edits, flatten routes with
discrete wires, and flatten routes with Maintain 3D Orientation segments.
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